aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mini-httpd/mini-httpd_1.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mini-httpd/mini-httpd_1.19.bb')
-rw-r--r--recipes/mini-httpd/mini-httpd_1.19.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/mini-httpd/mini-httpd_1.19.bb b/recipes/mini-httpd/mini-httpd_1.19.bb
new file mode 100644
index 0000000000..6ca44e79ee
--- /dev/null
+++ b/recipes/mini-httpd/mini-httpd_1.19.bb
@@ -0,0 +1,36 @@
+# Copyright (C) 2009 Khem Raj <raj.khem@gmail.org>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "mini_httpd is a small HTTP server. \
+ It implements all the basic features of an HTTP server \
+ It can also be configured to do SSL/HTTPS and IPv6. \
+ "
+HOMEPAGE = "http://www.acme.com/software/mini_httpd/"
+LICENSE = "BSD"
+SECTION = "net"
+DEPENDS = "openssl"
+PR = "r0"
+
+SRC_URI="http://www.acme.com/software/mini_httpd/mini_httpd-${PV}.tar.gz \
+ file://new-bindir-mandir.patch;patch=1 \
+ file://remove-CC.patch;patch=1 \
+ file://mini-httpd.conf \
+ file://init \
+ "
+
+INITSCRIPT_NAME = "mini_httpd"
+INITSCRIPT_PARAMS = "defaults"
+
+S = "${WORKDIR}/mini_httpd-${PV}"
+
+
+inherit autotools update-rc.d
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/mini-httpd
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/mini_httpd
+ install -m 0755 ${WORKDIR}/mini-httpd.conf ${D}${sysconfdir}/mini-httpd.conf
+ oe_runmake 'BINDIR=${D}${sbindir}' 'MANDIR=${D}${mandir}' install
+}