aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mml-widget
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mml-widget')
-rw-r--r--recipes/mml-widget/files/mathview-gcc43x.diff53
-rw-r--r--recipes/mml-widget/gtkmathview_0.7.6.bb18
-rw-r--r--recipes/mml-widget/gtkmathview_0.8.0.bb24
3 files changed, 95 insertions, 0 deletions
diff --git a/recipes/mml-widget/files/mathview-gcc43x.diff b/recipes/mml-widget/files/mathview-gcc43x.diff
new file mode 100644
index 0000000000..4091051a76
--- /dev/null
+++ b/recipes/mml-widget/files/mathview-gcc43x.diff
@@ -0,0 +1,53 @@
+--- /tmp/mathVariantAux.cc 2008-07-13 15:56:56.000000000 +0200
++++ gtkmathview-0.8.0/src/engine/mathml/mathVariantAux.cc 2008-07-13 15:57:46.893198000 +0200
+@@ -20,6 +20,8 @@
+
+ #include <cassert>
+
++#include <string.h>
++
+ #include "mathVariantAux.hh"
+
+ static MathVariantAttributes vattr[] = {
+--- /tmp/T1_FontDataBase.cc 2008-07-13 16:25:24.000000000 +0200
++++ gtkmathview-0.8.0/src/backend/ps/T1_FontDataBase.cc 2008-07-13 16:25:47.123198000 +0200
+@@ -20,6 +20,7 @@
+ #include <config.h>
+ #include <map>
+ #include <string>
++#include <string.h>
+ #include <stdlib.h>
+ #include <iostream>
+ #include <list>
+--- /tmp/SMS.cc 2008-07-13 16:27:23.000000000 +0200
++++ gtkmathview-0.8.0/mathmlsvg/SMS.cc 2008-07-13 16:27:41.543198000 +0200
+@@ -19,6 +19,7 @@
+ #include <config.h>
+
+ #include <sstream>
++#include <string.h>
+ #include "defs.h"
+ #include "AbstractLogger.hh"
+ #include "ValueConversion.hh"
+--- /tmp/main.cc 2008-07-13 16:29:11.000000000 +0200
++++ gtkmathview-0.8.0/mathmlsvg/main.cc 2008-07-13 16:29:28.813198000 +0200
+@@ -20,7 +20,7 @@
+
+ #include <cassert>
+ #include <fstream>
+-
++#include <string.h>
+ #include <popt.h>
+
+ // needed for old versions of GCC, must come before String.hh!
+--- /tmp/main.cc 2008-07-13 16:30:11.000000000 +0200
++++ gtkmathview-0.8.0/mathmlps/main.cc 2008-07-13 16:30:33.183198000 +0200
+@@ -20,7 +20,7 @@
+
+ #include <cassert>
+ #include <fstream>
+-
++#include <string.h>
+ #include <popt.h>
+
+ // needed for old versions of GCC, must come before String.hh!
diff --git a/recipes/mml-widget/gtkmathview_0.7.6.bb b/recipes/mml-widget/gtkmathview_0.7.6.bb
new file mode 100644
index 0000000000..55f4328f7e
--- /dev/null
+++ b/recipes/mml-widget/gtkmathview_0.7.6.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPL"
+HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
+DEPENDS = "gtk+ popt libxslt libxml2"
+
+SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-binreloc"
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/mml-widget/gtkmathview_0.8.0.bb b/recipes/mml-widget/gtkmathview_0.8.0.bb
new file mode 100644
index 0000000000..2fe48ea872
--- /dev/null
+++ b/recipes/mml-widget/gtkmathview_0.8.0.bb
@@ -0,0 +1,24 @@
+LICENSE = "GPL"
+HOMEPAGE = "http://helm.cs.unibo.it/mml-widget/"
+DEPENDS = "t1lib gtk+ popt libxslt libxml2"
+
+SRC_URI = "http://helm.cs.unibo.it/mml-widget/sources/${P}.tar.gz \
+ file://mathview-gcc43x.diff;patch=1 \
+ "
+
+inherit autotools
+AUTOTOOLS_STAGE_PKGCONFIG = 1
+
+EXTRA_OECONF = "--disable-binreloc"
+
+do_configure_prepend() {
+ sed -i -e s:AM_BINRELOC::g ${S}/configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+ for i in ${PKG_CONFIG_DIR}/*math*.pc ; do
+ sed -i -e s:${STAGING_INCDIR}:'${libdir}':g $i
+ done
+}
+