aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/monotone/files/txt2c-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/monotone/files/txt2c-cross.patch')
-rw-r--r--recipes/monotone/files/txt2c-cross.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/monotone/files/txt2c-cross.patch b/recipes/monotone/files/txt2c-cross.patch
new file mode 100644
index 0000000000..a50b8135fc
--- /dev/null
+++ b/recipes/monotone/files/txt2c-cross.patch
@@ -0,0 +1,15 @@
+# txt2c runs (only) on the build system. This is a fairly horrible
+# hack to make it compile with the build system compiler, not the
+# target compiler.
+
+--- monotone-0.19/Makefile.am.orig 2005-07-04 23:39:44.420722558 -0700
++++ monotone-0.19/Makefile.am 2005-07-04 23:36:50.267121331 -0700
+@@ -356,7 +356,7 @@
+ CLEANFILES = $(BUILT_SOURCES_CLEAN) $(EPS_FIGURES)
+
+ txt2c: txt2c.cc Makefile
+- $(CXX) -Wall -o $@ $<
++ $(BUILD_CXX) -Wall -o $@ $<
+ chmod 0755 $@$(EXEEXT)
+
+ apidocs: