aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/monotone/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/monotone/files')
-rw-r--r--recipes/monotone/files/configure.ac-no-sync-with-stdio-0.25.patch72
-rw-r--r--recipes/monotone/files/configure.ac-no-sync-with-stdio-0.26.patch127
-rw-r--r--recipes/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch10
-rw-r--r--recipes/monotone/files/configure.ac.patch36
-rw-r--r--recipes/monotone/files/cryptopp-endianness.patch40
-rw-r--r--recipes/monotone/files/txt2c-cross-post-0.22.patch11
-rw-r--r--recipes/monotone/files/txt2c-cross.patch15
-rw-r--r--recipes/monotone/files/uclibc.database.hh.stdarg.patch10
8 files changed, 321 insertions, 0 deletions
diff --git a/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.25.patch b/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.25.patch
new file mode 100644
index 0000000000..d2a77c6794
--- /dev/null
+++ b/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.25.patch
@@ -0,0 +1,72 @@
+*** monotone-0.25/configure.ac.orig Mon Apr 17 12:08:14 2006
+--- monotone-0.25/configure.ac Mon Apr 17 12:08:44 2006
+***************
+*** 471,537 ****
+ AC_CHECK_FUNC(getaddrinfo, [AM_CONDITIONAL(MISSING_GETADDRINFO, false)],
+ [AM_CONDITIONAL(MISSING_GETADDRINFO, true)])
+
+- # Check whether sync_with_stdio(false) run on C++ streams works correctly.
+- # It causes strange problems (EOF returned too early) on some versions of
+- # MinGW.
+- #
+- # In order to check for this issue, we first generate a large input file
+- # (over 128KB) and then try to read it (using a buffer size over 512
+- # bytes). If the amount of bytes read does not match the generated input,
+- # the implementation is broken.
+- AC_MSG_CHECKING(whether C++ streams support sync_with_stdio)
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
+- /*
+- * Generates the input file.
+- */
+- #include <cstdlib>
+- #include <fstream>
+-
+- int
+- main(void)
+- {
+- std::ofstream ofs("_conftest.dat");
+- for (int i = 0; i < 50000; i++)
+- ofs << "0123456789\r\n";
+- ofs.close();
+-
+- return EXIT_SUCCESS;
+- }
+- ])])
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
+- /*
+- * Reads the input file.
+- */
+- #include <cstdlib>
+- #include <fstream>
+- #include <iostream>
+-
+- int
+- main(int argc, char * argv[])
+- {
+- if (argc == 1)
+- return EXIT_SUCCESS;
+-
+- std::cin.sync_with_stdio(false);
+- int length = 0;
+- while (std::cin.good())
+- {
+- char buffer@<:@1024@:>@;
+- (void)std::cin.read(buffer, sizeof(buffer));
+- length += std::cin.gcount();
+- }
+-
+- return length == 600000 ? EXIT_SUCCESS : EXIT_FAILURE;
+- }
+- ])],
+- [if ./conftest$ac_exeext check_it_now <_conftest.dat; then
+- AC_MSG_RESULT(yes)
+ AC_DEFINE(SYNC_WITH_STDIO_WORKS, 1,
+ [Define to 1 if sync_with_stdio works fine on C++ streams])
+- else
+- AC_MSG_RESULT(no)
+- fi
+- rm -f _conftest.dat])
+
+ # allow compiling with different flags/optimisation
+ # for monotone versus libs, useful for testing.
+--- 471,478 ----
diff --git a/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.26.patch b/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.26.patch
new file mode 100644
index 0000000000..4c56061964
--- /dev/null
+++ b/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.26.patch
@@ -0,0 +1,127 @@
+--- /tmp/configure.ac 2006-04-28 16:40:37.670982792 +0200
++++ monotone-0.26/configure.ac 2006-04-28 16:42:22.762006528 +0200
+@@ -446,124 +446,8 @@
+ AC_CHECK_FUNC(getaddrinfo, [AM_CONDITIONAL(MISSING_GETADDRINFO, false)],
+ [AM_CONDITIONAL(MISSING_GETADDRINFO, true)])
+
+-# Check whether sync_with_stdio(false) run on C++ streams works correctly.
+-# It causes strange problems (EOF returned too early) on some versions of
+-# MinGW and OS X. The first test is for the MinGW issue, the second for
+-# the OS X issue.
+-#
+-# In order to check for this issue, we first generate a large input file
+-# (over 128KB) and then try to read it (using a buffer size over 512
+-# bytes). If the amount of bytes read does not match the generated input,
+-# the implementation is broken.
+-AC_MSG_CHECKING(whether C++ streams support sync_with_stdio)
+-AC_RUN_IFELSE([AC_LANG_SOURCE([
+-/*
+- * Generates the input file.
+- */
+-#include <cstdlib>
+-#include <fstream>
+-
+-int
+-main(void)
+-{
+- std::ofstream ofs("_conftest.dat");
+- for (int i = 0; i < 50000; i++)
+- ofs << "0123456789\r\n";
+- ofs.close();
+-
+- return EXIT_SUCCESS;
+-}
+-])])
+-AC_RUN_IFELSE([AC_LANG_SOURCE([
+-/*
+- * Reads the input file.
+- */
+-#include <cstdlib>
+-#include <fstream>
+-#include <iostream>
+-
+-int
+-main(int argc, char * argv[])
+-{
+- if (argc == 1)
+- return EXIT_SUCCESS;
+-
+- std::cin.sync_with_stdio(false);
+- int length = 0;
+- while (std::cin.good())
+- {
+- char buffer@<:@1024@:>@;
+- (void)std::cin.read(buffer, sizeof(buffer));
+- length += std::cin.gcount();
+- }
+-
+- return length == 600000 ? EXIT_SUCCESS : EXIT_FAILURE;
+-}
+-])],
+- [if ./conftest$ac_exeext check_it_now <_conftest.dat; then
+- AC_MSG_RESULT(yes)
+- ac_cv_sync_with_stdio=yes
+- else
+- AC_MSG_RESULT(no)
+- ac_cv_sync_with_stdio=no
+- fi
+- rm -f _conftest.dat])
+-
+-
+-# To check for this issue, we have a writer with a short delay between writes,
+-# and a reader who has set sync_with_stdio(false).
+-AC_MSG_CHECKING(whether C++ streams support sync_with_stdio 2)
+-AC_RUN_IFELSE([AC_LANG_SOURCE([
+-#include <cstdlib>
+-#include <iostream>
+-#ifdef WIN32
+-#define WIN32_LEAN_AND_MEAN
+-#include <windows.h>
+-#define sleep(x) Sleep((x) * 1000)
+-#else
+-#include <unistd.h>
+-#endif
+-
+-int
+-main(int argc, char * argv[])
+-{
+- if (argc == 1)
+- return EXIT_SUCCESS;
+-
+- if (argc == 2)
+- {
+- std::cin.sync_with_stdio(false);
+- int length = 0;
+- while (std::cin.good())
+- {
+- char buffer@<:@1024@:>@;
+- (void)std::cin.read(buffer, sizeof(buffer));
+- length += std::cin.gcount();
+- }
+-
+- return length == 82 ? EXIT_SUCCESS : EXIT_FAILURE;
+- }
+- else
+- {
+- std::cout << "1234567890123456789012345678901234567890" << std::endl;
+- sleep(1);
+- std::cout << "1234567890123456789012345678901234567890" << std::endl;
+- }
+- return EXIT_SUCCESS;
+-}
+-])],
+- [if ./conftest$ac_exeext check_it_now please | ./conftest$ac_exeext foo; then
+- AC_MSG_RESULT(yes)
+- ac_cv_sync_with_stdio_2=yes
+- else
+- AC_MSG_RESULT(no)
+- ac_cv_sync_with_stdio_2=no
+- fi])
+-
+-if test $ac_cv_sync_with_stdio = yes && test $ac_cv_sync_with_stdio_2 = yes; then
+ AC_DEFINE(SYNC_WITH_STDIO_WORKS, 1,
+ [Define to 1 if sync_with_stdio works fine on C++ streams])
+-fi
+
+ # allow compiling with different flags/optimisation
+ # for monotone versus libs, useful for testing.
diff --git a/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch b/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch
new file mode 100644
index 0000000000..60759fb727
--- /dev/null
+++ b/recipes/monotone/files/configure.ac-no-sync-with-stdio-0.31.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.ac 2006-12-18 12:14:47.000000000 +0100
++++ monotone-0.31/configure.ac 2006-12-18 12:15:58.022227000 +0100
+@@ -73,7 +73,6 @@
+ AC_CXX_STLPORT_HASHMAP
+ AC_CXX_TR1_UNORDERED_MAP
+ AC_CXX_TR1_UNORDERED_MAP_CONST_CORRECT
+-AC_CXX_SYNC_WITH_STDIO_WORKS
+ AC_CXX_TEMPLATE_STATIC_CONST_BUG
+
+ # Checks for typedefs and structures.
diff --git a/recipes/monotone/files/configure.ac.patch b/recipes/monotone/files/configure.ac.patch
new file mode 100644
index 0000000000..2d3e75531a
--- /dev/null
+++ b/recipes/monotone/files/configure.ac.patch
@@ -0,0 +1,36 @@
+--- monotone-0.21/configure.ac.orig 2005-07-17 19:23:29.580829434 -0700
++++ monotone-0.21/configure.ac 2005-07-17 19:28:50.237223287 -0700
+@@ -82,9 +82,14 @@
+ AC_DEFUN([BOOST_VERSION_CHECK],
+ [AC_CACHE_CHECK([boost version 1.32 or newer], ac_cv_version_boost,
+ [
+- AC_TRY_RUN(
++ AC_TRY_COMPILE(
+ [#include <boost/version.hpp>
+- int main() { return (BOOST_VERSION < 103200); }],
++ #if BOOST_VERSION < 103200
++ int main() { return (BOOST_VERSION < 103200); }
++ #else
++ #error boost version is ok
++ #endif
++ ],
+ ac_cv_version_boost=yes,
+ ac_cv_version_boost=no)
+ ])
+@@ -101,9 +106,14 @@
+ AC_DEFUN([BOOST_FIX_VERSION],
+ [AC_CACHE_CHECK([if boost requires extra flags to compile], ac_fix_boost,
+ [
+- AC_TRY_RUN(
++ AC_TRY_COMPILE(
+ [#include <boost/version.hpp>
+- int main() { return (BOOST_VERSION != 103200); }],
++ #if BOOST_VERSION != 103200
++ int main() { return (BOOST_VERSION != 103200); }
++ #else
++ #error boost version is not 1.32.0
++ #endif
++ ],
+ ac_fix_boost=yes,
+ ac_fix_boost=no)
+ ])
diff --git a/recipes/monotone/files/cryptopp-endianness.patch b/recipes/monotone/files/cryptopp-endianness.patch
new file mode 100644
index 0000000000..5d52b079bb
--- /dev/null
+++ b/recipes/monotone/files/cryptopp-endianness.patch
@@ -0,0 +1,40 @@
+--- monotone-0.20/.pc/cryptopp-endianness.patch/cryptopp/config.h 2005-07-05 22:56:31.000000000 -0700
++++ monotone-0.20/cryptopp/config.h 2005-07-12 12:01:02.626693397 -0700
+@@ -5,15 +5,28 @@
+
+ // ***************** Important Settings ********************
+
+-// define this if running on a big-endian CPU
+-#if !defined(IS_LITTLE_ENDIAN) && (defined(__BIG_ENDIAN__) || defined(__sparc) || defined(__sparc__) || defined(__hppa__) || defined(__mips__) || (defined(__MWERKS__) && !defined(__INTEL__)))
+-# define IS_BIG_ENDIAN
+-#endif
+-
+-// define this if running on a little-endian CPU
+-// big endian will be assumed if IS_LITTLE_ENDIAN is not defined
+-#ifndef IS_BIG_ENDIAN
+-# define IS_LITTLE_ENDIAN
++// this is GCC specific, but it is safe - the original version
++// of this file defaulted to little endian without warning...
++// The code will error out if an attempt is made to define
++// IS_LITTLE_ENDIAN or IS_BIG_ENDIAN elsewhere
++#ifndef __BYTE_ORDER
++# include <endian.h>
++# ifndef __BYTE_ORDER
++# error cryptopp needs the correct byte order from the compiler
++# endif
++#endif
++#if defined(IS_LITTLE_ENDIAN) || defined(IS_BIG_ENDIAN)
++ // It doesn't work to define this on the command line, at least
++ // with the original version
++# error cryptopp - unexpected endianness definition
++#endif
++
++#if defined(__LITTLE_ENDIAN) && __BYTE_ORDER == __LITTLE_ENDIAN
++# define IS_LITTLE_ENDIAN
++#elif defined(__BIG_ENDIAN) && __BYTE_ORDER == __BIG_ENDIAN
++# define IS_BIG_ENDIAN
++#else
++# error cryptopp - unknown endianness
+ #endif
+
+ // define this if you want to disable all OS-dependent features,
diff --git a/recipes/monotone/files/txt2c-cross-post-0.22.patch b/recipes/monotone/files/txt2c-cross-post-0.22.patch
new file mode 100644
index 0000000000..18ff9eb87c
--- /dev/null
+++ b/recipes/monotone/files/txt2c-cross-post-0.22.patch
@@ -0,0 +1,11 @@
+--- monotone-0.23/Makefile.am.orig 2005-10-02 23:32:09.876678400 -0700
++++ monotone-0.23/Makefile.am 2005-10-02 23:32:13.940934147 -0700
+@@ -427,7 +427,7 @@
+ CLEANFILES = $(BUILT_SOURCES_CLEAN) $(EPS_FIGURES)
+
+ txt2c: txt2c.cc Makefile
+- $(CXX) $(CXXFLAGS) -o $@ $<
++ $(BUILD_CXX) $(BUILD_CXXFLAGS) -o $@ $<
+ chmod 0755 $@$(EXEEXT)
+
+ apidocs:
diff --git a/recipes/monotone/files/txt2c-cross.patch b/recipes/monotone/files/txt2c-cross.patch
new file mode 100644
index 0000000000..a50b8135fc
--- /dev/null
+++ b/recipes/monotone/files/txt2c-cross.patch
@@ -0,0 +1,15 @@
+# txt2c runs (only) on the build system. This is a fairly horrible
+# hack to make it compile with the build system compiler, not the
+# target compiler.
+
+--- monotone-0.19/Makefile.am.orig 2005-07-04 23:39:44.420722558 -0700
++++ monotone-0.19/Makefile.am 2005-07-04 23:36:50.267121331 -0700
+@@ -356,7 +356,7 @@
+ CLEANFILES = $(BUILT_SOURCES_CLEAN) $(EPS_FIGURES)
+
+ txt2c: txt2c.cc Makefile
+- $(CXX) -Wall -o $@ $<
++ $(BUILD_CXX) -Wall -o $@ $<
+ chmod 0755 $@$(EXEEXT)
+
+ apidocs:
diff --git a/recipes/monotone/files/uclibc.database.hh.stdarg.patch b/recipes/monotone/files/uclibc.database.hh.stdarg.patch
new file mode 100644
index 0000000000..1590b7dded
--- /dev/null
+++ b/recipes/monotone/files/uclibc.database.hh.stdarg.patch
@@ -0,0 +1,10 @@
+--- monotone-0.21/database.hh.orig 2005-07-17 19:59:00.312846093 -0700
++++ monotone-0.21/database.hh 2005-07-17 19:59:56.259365537 -0700
+@@ -14,6 +14,7 @@
+ #include <set>
+ #include <map>
+ #include <string>
++#include <stdarg.h>
+
+ #include <boost/filesystem/path.hpp>
+