aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla/firefox_1.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mozilla/firefox_1.0.7.bb')
-rw-r--r--recipes/mozilla/firefox_1.0.7.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_1.0.7.bb b/recipes/mozilla/firefox_1.0.7.bb
new file mode 100644
index 0000000000..1b091bef64
--- /dev/null
+++ b/recipes/mozilla/firefox_1.0.7.bb
@@ -0,0 +1,22 @@
+PR = "r2"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://firefox-cc-fix.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1 \
+ file://firefox-1.0-gcc4-compile.patch;patch=1;pnum=0 \
+ file://xptcinvoke-arm.patch;patch=1 \
+ file://mozilla-eabi.patch;patch=1"
+S = "${WORKDIR}/mozilla"
+
+inherit autotools mozilla
+
+require firefox.inc
+
+EXTRA_OECONF += " --with-gssapi=${STAGING_LIBDIR}/../"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+}