summaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/rhino-native_1.7r1.bb5
-rw-r--r--recipes/mozilla/rhino_1.7r1.bb7
2 files changed, 7 insertions, 5 deletions
diff --git a/recipes/mozilla/rhino-native_1.7r1.bb b/recipes/mozilla/rhino-native_1.7r1.bb
deleted file mode 100644
index 1b563603f8..0000000000
--- a/recipes/mozilla/rhino-native_1.7r1.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require rhino_${PV}.bb
-
-inherit java-native
-
-RDEPENDS_${PN} = ""
diff --git a/recipes/mozilla/rhino_1.7r1.bb b/recipes/mozilla/rhino_1.7r1.bb
index b7b5d9e7d2..49addfda29 100644
--- a/recipes/mozilla/rhino_1.7r1.bb
+++ b/recipes/mozilla/rhino_1.7r1.bb
@@ -4,6 +4,8 @@ LICENSE = "GPL MPL"
DEPENDS = "fastjar-native"
+PR = "r1"
+
inherit java-library
SRC_URI = "\
@@ -17,7 +19,9 @@ S = "${WORKDIR}/rhino1_7R1"
PACKAGES = "${JPN} rhino"
FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
+
RDEPENDS_${PN} = "java2-runtime ${JPN}"
+RDEPENDS_${PN}_virtclass-native = ""
do_compile() {
mkdir -p build
@@ -43,3 +47,6 @@ do_install_append() {
SRC_URI[md5sum] = "613eed8201d37be201805e5048ebb0c3"
SRC_URI[sha256sum] = "084e250d2392369b2548b663e61bcf128baecb2f527e381e9ba89f0148db2c0d"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"