summaryrefslogtreecommitdiffstats
path: root/recipes/mplayer/mplayer
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mplayer/mplayer')
-rw-r--r--recipes/mplayer/mplayer/mplayer-git_omapfb.patch33
-rw-r--r--recipes/mplayer/mplayer/omapfb_control_arguments.patch13
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/mplayer/mplayer/mplayer-git_omapfb.patch b/recipes/mplayer/mplayer/mplayer-git_omapfb.patch
new file mode 100644
index 0000000000..f5d41e937e
--- /dev/null
+++ b/recipes/mplayer/mplayer/mplayer-git_omapfb.patch
@@ -0,0 +1,33 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile 2010-09-12 21:47:39.272215523 +0200
++++ git/Makefile 2010-09-12 21:49:13.359100591 +0200
+@@ -538,7 +538,7 @@
+ SRCS_MPLAYER-$(DXR2) += libao2/ao_dxr2.c libvo/vo_dxr2.c
+ SRCS_MPLAYER-$(DXR3) += libvo/vo_dxr3.c
+ SRCS_MPLAYER-$(ESD) += libao2/ao_esd.c
+-SRCS_MPLAYER-$(FBDEV) += libvo/vo_fbdev.c libvo/vo_fbdev2.c
++SRCS_MPLAYER-$(FBDEV) += libvo/vo_fbdev.c libvo/vo_fbdev2.c libvo/vo_omapfb.c libvo/yuv.S
+ SRCS_MPLAYER-$(GGI) += libvo/vo_ggi.c
+ SRCS_MPLAYER-$(GIF) += libvo/vo_gif89a.c
+ SRCS_MPLAYER-$(GL) += libvo/gl_common.c libvo/vo_gl.c \
+Index: git/libvo/video_out.c
+===================================================================
+--- git.orig/libvo/video_out.c 2010-09-12 21:47:49.882156069 +0200
++++ git/libvo/video_out.c 2010-09-12 21:49:13.359100591 +0200
+@@ -101,6 +101,7 @@
+ extern struct vo_driver video_out_bl;
+ extern struct vo_driver video_out_fbdev;
+ extern struct vo_driver video_out_fbdev2;
++extern struct vo_driver video_out_omapfb;
+ extern struct vo_driver video_out_svga;
+ extern struct vo_driver video_out_png;
+ extern struct vo_driver video_out_ggi;
+@@ -202,6 +203,7 @@
+ #ifdef CONFIG_FBDEV
+ &video_out_fbdev,
+ &video_out_fbdev2,
++ &video_out_omapfb,
+ #endif
+ #ifdef CONFIG_SVGALIB
+ &video_out_svga,
diff --git a/recipes/mplayer/mplayer/omapfb_control_arguments.patch b/recipes/mplayer/mplayer/omapfb_control_arguments.patch
new file mode 100644
index 0000000000..04351112b0
--- /dev/null
+++ b/recipes/mplayer/mplayer/omapfb_control_arguments.patch
@@ -0,0 +1,13 @@
+Index: mplayer-0.0+1.0rc4+gitr0+d1c686f6a63c31276b0811baf7c78aa6f4c6c6a6-r5/vo_omapfb.c
+===================================================================
+--- mplayer-0.0+1.0rc4+gitr0+d1c686f6a63c31276b0811baf7c78aa6f4c6c6a6-r5.orig/vo_omapfb.c 2010-09-12 22:42:52.589660557 +0200
++++ mplayer-0.0+1.0rc4+gitr0+d1c686f6a63c31276b0811baf7c78aa6f4c6c6a6-r5/vo_omapfb.c 2010-09-12 22:43:01.759065169 +0200
+@@ -556,7 +556,7 @@
+ }
+
+
+-static int control(uint32_t request, void *data, ...)
++static int control(uint32_t request, void *data)
+ {
+ switch (request) {
+ case VOCTRL_QUERY_FORMAT: