aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mumpot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mumpot')
-rw-r--r--recipes/mumpot/files/mumpot-cyclemap.desktop8
-rw-r--r--recipes/mumpot/files/mumpot-mapnik.desktop8
-rw-r--r--recipes/mumpot/files/mumpot-tah.desktop8
-rw-r--r--recipes/mumpot/mumpot_0.4.bb20
4 files changed, 44 insertions, 0 deletions
diff --git a/recipes/mumpot/files/mumpot-cyclemap.desktop b/recipes/mumpot/files/mumpot-cyclemap.desktop
new file mode 100644
index 0000000000..495e712bac
--- /dev/null
+++ b/recipes/mumpot/files/mumpot-cyclemap.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot cyclemap
+Comment=Mumpot cyclemap
+Exec=mumpot-cyclemap
+Terminal=0
+Type=Application
+Categories=X-PIM;GTK;Education;Science;Geography;
+StartupNotify=True
diff --git a/recipes/mumpot/files/mumpot-mapnik.desktop b/recipes/mumpot/files/mumpot-mapnik.desktop
new file mode 100644
index 0000000000..9d852d2577
--- /dev/null
+++ b/recipes/mumpot/files/mumpot-mapnik.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot Mapnik
+Comment=Mumpot Mapnuk
+Exec=mumpot-mapnik
+Terminal=0
+Type=Application
+Categories=X-PIM;GTK;Education;Science;Geography;
+StartupNotify=True
diff --git a/recipes/mumpot/files/mumpot-tah.desktop b/recipes/mumpot/files/mumpot-tah.desktop
new file mode 100644
index 0000000000..805c1d42d9
--- /dev/null
+++ b/recipes/mumpot/files/mumpot-tah.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot t@h
+Comment=Mumpot t@h
+Exec=mumpot-tah
+Terminal=0
+Type=Application
+Categories=X-PIM;GTK;Education;Science;Geography;
+StartupNotify=True
diff --git a/recipes/mumpot/mumpot_0.4.bb b/recipes/mumpot/mumpot_0.4.bb
new file mode 100644
index 0000000000..ab9d876902
--- /dev/null
+++ b/recipes/mumpot/mumpot_0.4.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A map-viewer, simple editor and routing application for OSM maps"
+HOMEPAGE = "http://www.mumpot.org/"
+AUTHOR = "Andreas Kemnade"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+DEPENDS = "gtk+ bluez-libs bzip2 libxml2 libpng jpeg"
+
+SRC_URI = "http://www.mumpot.org/download/mumpot-${PV}.tar.gz \
+ file://mumpot-tah.desktop \
+ file://mumpot-mapnik.desktop \
+ file://mumpot-cyclemap.desktop"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/mumpot-tah.desktop ${D}${datadir}/applications/mumpot-tah.desktop
+ install -m 0644 ${WORKDIR}/mumpot-mapnik.desktop ${D}${datadir}/applications/mumpot-mapnik.desktop
+ install -m 0644 ${WORKDIR}/mumpot-cyclemap.desktop ${D}${datadir}/applications/mumpot-cyclemap.desktop
+}