summaryrefslogtreecommitdiffstats
path: root/recipes/nautilus
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nautilus')
-rw-r--r--recipes/nautilus/nautilus-cd-burner/makefile.patch42
-rw-r--r--recipes/nautilus/nautilus-cd-burner_2.8.5.bb30
-rw-r--r--recipes/nautilus/nautilus_2.12.2.bb19
-rw-r--r--recipes/nautilus/nautilus_2.22.5.bb20
-rw-r--r--recipes/nautilus/nautilus_2.24.1.bb22
-rw-r--r--recipes/nautilus/nautilus_2.24.2.bb29
-rw-r--r--recipes/nautilus/nautilus_2.6.1.bb47
7 files changed, 209 insertions, 0 deletions
diff --git a/recipes/nautilus/nautilus-cd-burner/makefile.patch b/recipes/nautilus/nautilus-cd-burner/makefile.patch
new file mode 100644
index 0000000000..ece201e25d
--- /dev/null
+++ b/recipes/nautilus/nautilus-cd-burner/makefile.patch
@@ -0,0 +1,42 @@
+--- nautilus-cd-burner-2.8.5/Makefile.am 2004-10-20 15:52:13.000000000 -0700
++++ nautilus-cd-burner-2.8.5.new/Makefile.am 2004-11-15 16:57:16.530130640 -0700
+@@ -52,6 +51,8 @@
+ CLEANFILES = $(desktop_in_files:.desktop.in=.desktop) \
+ $(schema_DATA) $(CDRECMARSHALFILES)
+
++DISTCLEANFILES = intltool-extract intltool-merge intltool-update
++
+ modulesconfdir=$(sysconfdir)/gnome-vfs-2.0/modules
+ modulesconf_DATA = mapping-modules.conf
+ modulesdir = $(libdir)/gnome-vfs-2.0/modules
+@@ -109,6 +110,12 @@
+ mapping-protocol.c \
+ $(NULL)
+
++# we set this so that Automake will use different file names when
++# compiling, so that the copy of mapping-method.o compiled for
++# libmapping.la doesn't conflict with the copy compiled for
++# mapping-daemon (the library one should be PIC code).
++libmapping_la_CFLAGS =
++
+ libmapping_la_LDFLAGS = $(module_flags)
+ libmapping_la_LIBADD = $(MAPPING_LIBS)
+
+@@ -142,12 +149,11 @@
+
+ if LIBSTDCXX_HACK
+ AM_CXXFLAGS = -fno-exceptions -fno-rtti
+-CXXLD=--tag=CC $(CXX)
+-else
+-# If we don't set it, it doesn't seem to appear in the Makefile at all
+-# and we can't recursively set it, hence
+-CXXLD=$(CXX)
+-endif
++CXX_LINK_TAG = --tag=CC
++endif
++CXXLINK = $(LIBTOOL) --mode=link $(CXX_LINK_TAG) $(CXXLD) $(AM_CXXFLAGS) \
++ $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
++
+
+ libnautilus_burn_la_LIBADD = $(BURN_LIBS)
+ libnautilus_burnincludedir = $(includedir)/libnautilus-burn/
diff --git a/recipes/nautilus/nautilus-cd-burner_2.8.5.bb b/recipes/nautilus/nautilus-cd-burner_2.8.5.bb
new file mode 100644
index 0000000000..71f0a5c44e
--- /dev/null
+++ b/recipes/nautilus/nautilus-cd-burner_2.8.5.bb
@@ -0,0 +1,30 @@
+# nautilus-cd-burner OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+LICENSE="GPL"
+
+DEPENDS="nautilus"
+
+SRC_URI += "file://makefile.patch;patch=1"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+PACKAGES += "libnautilus-burn"
+
+FILES_${PN} = "/usr/share/* /usr/bin/* /etc /usr/lib/gnome-vfs-2.0/* \
+ /usr/lib/nautilus/*"
+FILES_libnautilus-burn="/usr/lib/*.so*"
+
+headers="bacon-cd-selection.h cd-drive.h cd-recorder.h"
+hdir="${STAGING_INCDIR}/libnautilus-burn"
+
+do_stage() {
+ install -d ${hdir}
+ for file in ${headers}; do
+ install -m 0644 $file ${hdir}/$file
+ done
+
+ oe_libinstall libnautilus-burn ${STAGING_LIBDIR}
+}
diff --git a/recipes/nautilus/nautilus_2.12.2.bb b/recipes/nautilus/nautilus_2.12.2.bb
new file mode 100644
index 0000000000..2f5628073e
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.12.2.bb
@@ -0,0 +1,19 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+LICENSE="GPL"
+
+DEPENDS="librsvg libexif eel esound gnome-desktop"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+PACKAGES += "libnautilus"
+
+FILES_${PN} = "/usr/bin/* /usr/libexec/* /usr/lib/bonobo/* /usr/share/* /etc/*"
+FILES_libnautilus = "/usr/lib/*.so*"
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/nautilus/nautilus_2.22.5.bb b/recipes/nautilus/nautilus_2.22.5.bb
new file mode 100644
index 0000000000..0e94b93698
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.22.5.bb
@@ -0,0 +1,20 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+LICENSE="GPL"
+
+DEPENDS = "librsvg libexif eel esound gnome-desktop"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+PACKAGES += "libnautilus"
+
+FILES_${PN} += "${datadir}/icons ${datadir}/mime /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/nautilus/nautilus_2.24.1.bb b/recipes/nautilus/nautilus_2.24.1.bb
new file mode 100644
index 0000000000..4e0f33282d
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.24.1.bb
@@ -0,0 +1,22 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+PR = "r4"
+
+inherit gnome
+LICENSE="GPL"
+
+DEPENDS += " tracker librsvg libexif eel esound gnome-desktop"
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/nautilus/nautilus_2.24.2.bb b/recipes/nautilus/nautilus_2.24.2.bb
new file mode 100644
index 0000000000..30915b75fc
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.24.2.bb
@@ -0,0 +1,29 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+LICENSE="GPL"
+
+PR = "r1"
+
+DEPENDS += " gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
+RDEPENDS = "gvfs"
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/nautilus/nautilus_2.6.1.bb b/recipes/nautilus/nautilus_2.6.1.bb
new file mode 100644
index 0000000000..66139eeb2f
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.6.1.bb
@@ -0,0 +1,47 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+LICENSE="GPL"
+
+DEPENDS="librsvg eel esound gnome-desktop"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+PACKAGES += "libnautilus"
+
+FILES_${PN} = "/usr/bin/* /usr/libexec/* /usr/lib/bonobo/* /usr/share/* /etc/*"
+FILES_libnautilus = "/usr/lib/*.so*"
+
+libnheaders="libnautilus.h nautilus-undo-private.h \
+ nautilus-bonobo-ui.h nautilus-undo.h \
+ nautilus-clipboard.h nautilus-view-component.h \
+ nautilus-distributed-undo.h nautilus-view-standard-main.h \
+ nautilus-idle-queue.h nautilus-view.h \
+ nautilus-scroll-positionable.h"
+
+nextheaders="nautilus-column-provider.h nautilus-menu-item.h \
+ nautilus-column.h nautilus-menu-provider.h \
+ nautilus-extension-types.h nautilus-property-page-provider.h \
+ nautilus-file-info.h nautilus-property-page.h \
+ nautilus-info-provider.h"
+
+libndir="${STAGING_INCDIR}/libnautilus"
+nextdir="${STAGING_INCDIR}/nautilus/libnautilus-extension"
+
+do_stage() {
+ install -d ${libndir} ${nextdir}
+ for file in ${libnheaders}; do
+ install -m 0644 libnautilus/$file ${libndir}/$file
+ done
+
+ for file in ${nextheaders}; do
+ install -m 0644 libnautilus-extension/$file ${nextdir}/$file
+ done
+
+ oe_libinstall -C libnautilus-adapter libnautilus-adapter ${STAGING_LIBDIR}
+ oe_libinstall -C libnautilus-extension libnautilus-extension ${STAGING_LIBDIR}
+ oe_libinstall -C libnautilus-private libnautilus-private ${STAGING_LIBDIR}
+ oe_libinstall -C libnautilus libnautilus ${STAGING_LIBDIR}
+}