aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ncftp/ncftp/make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ncftp/ncftp/make.patch')
-rw-r--r--recipes/ncftp/ncftp/make.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/ncftp/ncftp/make.patch b/recipes/ncftp/ncftp/make.patch
new file mode 100644
index 0000000000..78bc523ee7
--- /dev/null
+++ b/recipes/ncftp/ncftp/make.patch
@@ -0,0 +1,39 @@
+Index: ncftp-3.2.0/Strn/Makefile.in
+===================================================================
+--- ncftp-3.2.0.orig/Strn/Makefile.in 2006-12-18 22:11:48.000000000 +0100
++++ ncftp-3.2.0/Strn/Makefile.in 2006-12-18 22:12:48.000000000 +0100
+@@ -42,7 +42,7 @@
+ static: $(LIB)
+
+ $(LIB): $(OBJS)
+- @CCDV@@AR@ r $(LIB) $(OBJS)
++ @CCDV@$(AR) r $(LIB) $(OBJS)
+ -@chmod 644 "$(LIB)"
+ -@RANLIB@ "$(LIB)"
+ -@echo "$(VER)" > Strn.version
+Index: ncftp-3.2.0/sio/Makefile.in
+===================================================================
+--- ncftp-3.2.0.orig/sio/Makefile.in 2006-12-18 22:15:39.000000000 +0100
++++ ncftp-3.2.0/sio/Makefile.in 2006-12-18 22:15:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ $(LIB): $(OBJS)
+ -@/bin/rm -f $(LIB)
+- @CCDV@@AR@ r $(LIB) $(OBJS)
++ @CCDV@$(AR) r $(LIB) $(OBJS)
+ -@RANLIB@ $(LIB)
+ -@echo $(VER) > sio.version
+ -@chmod a+r $(LIB) sio.h usio.h
+Index: ncftp-3.2.0/libncftp/Makefile.in
+===================================================================
+--- ncftp-3.2.0.orig/libncftp/Makefile.in 2006-12-18 22:16:42.000000000 +0100
++++ ncftp-3.2.0/libncftp/Makefile.in 2006-12-18 22:16:56.000000000 +0100
+@@ -49,7 +49,7 @@
+
+ $(LIB): $(OBJS)
+ -@/bin/rm -f $(LIB)
+- @CCDV@@AR@ r $(LIB) $(OBJS)
++ @CCDV@$(AR) r $(LIB) $(OBJS)
+ -@chmod 644 $(LIB)
+ -@@RANLIB@ $(LIB)
+ @/bin/ls -l $(LIB)