summaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/pixdev/pixdev-stable_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking/pixdev/pixdev-stable_0.1.bb')
-rw-r--r--recipes/nonworking/pixdev/pixdev-stable_0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/nonworking/pixdev/pixdev-stable_0.1.bb b/recipes/nonworking/pixdev/pixdev-stable_0.1.bb
new file mode 100644
index 0000000000..78a658d7e7
--- /dev/null
+++ b/recipes/nonworking/pixdev/pixdev-stable_0.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Pixil Operating Environment"
+SECTION = "gui"
+PRIORITY = "optional"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pixdev/pixdev-stable-${PV}.tar.gz \
+ file://${FILESDIR}/braces.patch;patch=1"
+export EXTRA_OEMAKE=
+
+inherit autotools
+
+do_compile() {
+ if [ "${MACHINE}" = "ipaq" ]; then CONFIG=defconfig_ipaq; fi
+ if [ "${MACHINE}" = "collie" ]; then CONFIG=defconfig_zaurus; fi
+
+ if [ -z "$CONFIG" ]; then CONFIG=defconfig; fi
+
+ oe_runmake $CONFIG
+ oe_runmake MWDIR=${STAGING_DIR_TARGET} "TARGET_CROSS=${TARGET_PREFIX}" all
+}
+
+do_install() {
+ install -d ${D}/${prefix}/pixil
+
+ oe_runmake "TARGET_CROSS=${TARGET_PREFIX}" INSTALL_DIR=${D}/${prefix}/pixil \
+ DEST_DIR=/${prefix}/pixil install
+}