summaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/r/r-native_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking/r/r-native_2.0.0.bb')
-rw-r--r--recipes/nonworking/r/r-native_2.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/nonworking/r/r-native_2.0.0.bb b/recipes/nonworking/r/r-native_2.0.0.bb
new file mode 100644
index 0000000000..d9360dfaef
--- /dev/null
+++ b/recipes/nonworking/r/r-native_2.0.0.bb
@@ -0,0 +1,20 @@
+DEPENDS = "ncurses-native perl-native"
+
+SRC_URI = "http://www.stats.bris.ac.uk/R/src/base/R-2/R-${PV}.tar.gz"
+
+EXTRA_OECONF = "--without-x --without-readline --without-gnome --without-tcltk --without-libpng \
+ --without-jpeglib"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/R-${PV}"
+
+S = "${WORKDIR}/R-${PV}"
+
+inherit autotools native
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ install -m 0755 ${S}/bin/R ${STAGING_BINDIR}/R
+}