summaryrefslogtreecommitdiffstats
path: root/recipes/nonworking
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking')
-rw-r--r--recipes/nonworking/unionfs/unionfs-modules.inc38
-rw-r--r--recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb4
-rw-r--r--recipes/nonworking/unionfs/unionfs-modules_1.0.13.bb11
3 files changed, 53 insertions, 0 deletions
diff --git a/recipes/nonworking/unionfs/unionfs-modules.inc b/recipes/nonworking/unionfs/unionfs-modules.inc
new file mode 100644
index 0000000000..5e87288e48
--- /dev/null
+++ b/recipes/nonworking/unionfs/unionfs-modules.inc
@@ -0,0 +1,38 @@
+unionutils = "unionctl uniondbg"
+
+include unionfs.inc
+inherit module
+
+SECTION = "kernel/modules"
+
+EXTRA_OEMAKE = "'CC=${KERNEL_CC}' 'LD=${KERNEL_LD}' \
+ 'KERNELVER=${KERNEL_VERSION}' \
+ 'LINUXSRC=${STAGING_KERNEL_DIR}' \
+ 'CROSS_COMPILE=${TARGET_PREFIX}' \
+ 'OS=${TARGET_OS}' \
+ ${@get_flags(d, bb)}"
+
+KCFLAGS = "-D__KERNEL__ -DMODULE -DFISTGEN \
+ -DUNIONFS_UNSUPPORTED -DNODEBUG \
+ -I. -I${STAGING_KERNEL_DIR}/include \
+ -DUNIONFS_VERSION=\"${PV}\" \
+ ${CFLAGS}"
+
+def get_flags(d, bb):
+ ret = ""
+ if bb.data.getVar('KERNEL_OBJECT_SUFFIX', d, 1) == '.ko':
+ return "'EXTRA_CFLAGS=%s'" % bb.data.getVar('KCFLAGS', d, 1)
+ return "'CFLAGS=%s'" % bb.data.getVar('KCFLAGS', d, 1)
+
+do_compile () {
+ unset LDFLAGS
+ oe_runmake unionfs${KERNEL_OBJECT_SUFFIX}
+}
+
+do_install () {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/fs
+ install -m 0644 unionfs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/fs/
+
+ install -d ${D}${mandir}/man4
+ install -m 0644 man/unionfs.4 ${D}${mandir}/man4/
+}
diff --git a/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb b/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb
new file mode 100644
index 0000000000..c9ca1d130d
--- /dev/null
+++ b/recipes/nonworking/unionfs/unionfs-modules_1.0.11.bb
@@ -0,0 +1,4 @@
+require unionfs-modules.inc
+require unionfs.inc
+
+SRC_URI += "file://make.patch;patch=1"
diff --git a/recipes/nonworking/unionfs/unionfs-modules_1.0.13.bb b/recipes/nonworking/unionfs/unionfs-modules_1.0.13.bb
new file mode 100644
index 0000000000..6a7d880720
--- /dev/null
+++ b/recipes/nonworking/unionfs/unionfs-modules_1.0.13.bb
@@ -0,0 +1,11 @@
+PR = "r1"
+PARALLEL_MAKE = ""
+
+require unionfs-modules.inc
+
+KERNEL_MAJMIN = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')[:3]}"
+
+do_compile() {
+ unset LDFLAGS
+ oe_runmake unionfs${KERNEL_MAJMIN}
+}