summaryrefslogtreecommitdiffstats
path: root/recipes/nonworking
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking')
-rw-r--r--recipes/nonworking/giac/giac_0.5.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/nonworking/giac/giac_0.5.0.bb b/recipes/nonworking/giac/giac_0.5.0.bb
new file mode 100644
index 0000000000..36df3c22b7
--- /dev/null
+++ b/recipes/nonworking/giac/giac_0.5.0.bb
@@ -0,0 +1,38 @@
+SECTION = "console/utils"
+DESCRIPTION = "A free computer algebra system"
+HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk gmp mpfr gsl"
+# ntl pari"
+
+SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
+
+inherit autotools
+
+PACKAGES += " lib${PN}"
+FILES_${PN} = "${bindir} \
+ ${datadir}/${PN}"
+FILES_lib${PN} = "${libdir}"
+
+# breaks the build...
+#EXTRA_OECONF = "--enable-debug=no"
+
+# skip autoreconf for now (fails due to improper local macros)
+do_configure() {
+ oe_runconf
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+
+ # put the docs where they belong
+ # might need further investigation in case giac needs
+ # them in the original place
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN}/doc ${D}${docdir}/${PN}
+}