aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nrlolsr/nrlolsr_7.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nrlolsr/nrlolsr_7.8.1.bb')
-rw-r--r--recipes/nrlolsr/nrlolsr_7.8.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/nrlolsr/nrlolsr_7.8.1.bb b/recipes/nrlolsr/nrlolsr_7.8.1.bb
new file mode 100644
index 0000000000..3fa5e2f4df
--- /dev/null
+++ b/recipes/nrlolsr/nrlolsr_7.8.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "NRL OLSR - added to OE to support the Maniac Challenge (http://www.maniacchallenge.org/)"
+SECTION = "applications"
+LICENSE = "Public Domain"
+
+S="${WORKDIR}/nrlolsr/"
+
+SRC_URI = "http://downloads.pf.itd.nrl.navy.mil/olsr/nrlolsrdv7.8.1.tgz \
+ file://nrlolsr-cross.patch;patch=1 \
+ "
+
+do_compile () {
+ cd ${S}/unix
+
+ sed -i -e 's:-I/usr/X11R6/include:-I${STAGING_INCDIR}:g' Makefile.linux
+ sed -i -e 's:-L/usr/X11R6/lib:-L${STAGING_LIBDIR}:g' Makefile.linux
+ sed -i -e 's:/usr/local/bin:${STAGING_BINDIR}:g' Makefile.linux
+ sed -i -e 's:make -f Makefile:make -e -f Makefile:g' Makefile.common
+
+# EXTRA_OEMAKE="-f Makefile.linux"
+ oe_runmake -f Makefile.linux
+
+}
+
+do_install () {
+ install -d ${D}/${bindir}
+ install unix/nrlolsrd ${D}/${bindir}
+}