aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ntop/ntop_3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ntop/ntop_3.0.bb')
-rw-r--r--recipes/ntop/ntop_3.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/ntop/ntop_3.0.bb b/recipes/ntop/ntop_3.0.bb
new file mode 100644
index 0000000000..aa725222e9
--- /dev/null
+++ b/recipes/ntop/ntop_3.0.bb
@@ -0,0 +1,38 @@
+LICENSE = "GPL"
+DESCRIPTION = "ntop is network top"
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "gdbm zlib libpcap libpng gd"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tgz \
+ file://${FILESDIR}/autotools.patch;patch=1 \
+ file://${FILESDIR}/plugins.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF += " --without-ssl \
+ --with-gd-lib=${STAGING_LIBDIR} \
+ --with-gd-include=${STAGING_INCDIR} \
+ --with-zlib-lib=${STAGING_LIBDIR} \
+ --with-zlib-include=${STAGING_INCDIR} \
+ --with-pcap-lib=${STAGING_LIBDIR} \
+ --with-pcap-include=${STAGING_INCDIR} \
+ --with-libpng-lib=${STAGING_LIBDIR} \
+ --with-libpng-include=${STAGING_INCDIR} \
+ --with-gdbm-lib=${STAGING_LIBDIR} \
+ --with-gdbm-include=${STAGING_INCDIR}"
+
+FILES_ntop_append = " ${libdir}/ntop/plugins/*.so ${libdir}/libntop-*.so \
+ ${libdir}/libntopreport-*.so"
+FILES_${PN}-dev = "${includedir} ${libdir}/libntop.so ${libdir}/libntopreport.so \
+ ${libdir}/*.a ${libdir}/libntopreport.a ${libdir}/*.la"
+FILES_${PN}-dbg += "${libdir}/ntop/plugins/.debug"
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ mv acinclude.m4.ntop acinclude.m4
+ fi
+ rm -f libtool
+ cp ${STAGING_BINDIR_NATIVE}/${TARGET_SYS}-libtool libtool
+}