aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/efl1/epsilon_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/efl1/epsilon_svn.bb')
-rw-r--r--recipes/obsolete/efl1/epsilon_svn.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/obsolete/efl1/epsilon_svn.bb b/recipes/obsolete/efl1/epsilon_svn.bb
new file mode 100644
index 0000000000..14eb2d27a2
--- /dev/null
+++ b/recipes/obsolete/efl1/epsilon_svn.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Epsilon is a flexible and powerful image thumbnailing library \
+that is compliant with the freedesktop.org Thumbnail Managing Standard."
+LICENSE = "MIT BSD"
+# can also depend on xine for movie thumbnails
+DEPENDS = "libpng evas ecore edje perl-native"
+PV = "0.3.0.012+svnr${SRCPV}"
+PR = "r4"
+
+inherit efl
+
+SRCREV = "${EFL_SRCREV}"
+SRC_URI = "svn://svn.enlightenment.org/svn/e/OLD;module=${SRCNAME};proto=http"
+
+# a gstreamer thumbnailer would be nice now that we have emotion using gstreamer as well
+EXTRA_OECONF = "--disable-xine"
+
+# package the thumb daemon seperately
+PACKAGES =+ "${PN}-thumbd"
+FILES_${PN}-thumbd = "${bindir}/epsilon ${bindir}/epsilon_thumbd"
+RRECOMMENDS_${PN} = "${PN}-thumbd"
+
+FILES_${PN}-dev += "${libdir}/${PN}/*/*.a ${libdir}/${PN}/*/*.la"
+FILES_${PN}-dbg += "${libdir}/${PN}/plugins/.debug/*.so"
+