aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/mysql/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/mysql/files')
-rw-r--r--recipes/obsolete/mysql/files/gen_lex_hash.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/obsolete/mysql/files/gen_lex_hash.patch b/recipes/obsolete/mysql/files/gen_lex_hash.patch
new file mode 100644
index 0000000000..c398d048dc
--- /dev/null
+++ b/recipes/obsolete/mysql/files/gen_lex_hash.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mysql-4.1.15/sql/Makefile.am~gen_lexhash
++++ mysql-4.1.15/sql/Makefile.am
+@@ -137,8 +137,10 @@
+ @echo "If it fails, re-run configure with --with-low-memory"
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
+ lex_hash.h: gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@
++ $(GEN_LEX_HASH) > $@
+
+ # For testing of udf_example.so; Works on platforms with gcc
+ # (This is not part of our build process but only provided as an example)