aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch')
-rw-r--r--recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch b/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch
new file mode 100644
index 0000000000..c8b7cc805a
--- /dev/null
+++ b/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch
@@ -0,0 +1,16 @@
+Index: pydirectfb/setup.py
+===================================================================
+--- pydirectfb.orig/setup.py
++++ pydirectfb/setup.py
+@@ -11,9 +11,10 @@
+ Check dependencies add add the flags to include_dirs, library_dirs and
+ libraries. The basic logic is taken from pygame.
+ """
+- command = name + '-config --version --cflags --libs 2>/dev/null'
++ command = 'pkg-config %s --modversion --cflags --libs 2>/dev/null' % name
+ try:
+ config = os.popen(command).readlines()
++ print config
+ if len(config) == 0:
+ raise ValueError, 'command not found'
+ flags = (' '.join(config[1:]) + ' ').split()