aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/qiv/qiv_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/qiv/qiv_1.9.bb')
-rw-r--r--recipes/obsolete/qiv/qiv_1.9.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/obsolete/qiv/qiv_1.9.bb b/recipes/obsolete/qiv/qiv_1.9.bb
new file mode 100644
index 0000000000..a1b63c6c61
--- /dev/null
+++ b/recipes/obsolete/qiv/qiv_1.9.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Qiv is a very small and pretty fast gdk/Imlib image viewer."
+LICENSE = "GPLv2"
+SECTION = "x11/graphics"
+DEPENDS = "gtk+-1.2 imlib"
+PR = "r1"
+
+SRC_URI = "http://www.klografx.net/qiv/download/qiv-1.9-src.tgz \
+ file://makefile.patch \
+ "
+inherit pkgconfig binconfig
+
+CFLAGS += " -lSM -lICE -lXdmcp"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1/
+
+ install -s -m 0755 qiv ${D}${bindir}/qiv
+ install -m 0644 qiv.1 ${D}${mandir}/man1/qiv.1
+}
+
+SRC_URI[md5sum] = "b368e00543b2b1d9a87b37fd5ba60c57"
+SRC_URI[sha256sum] = "7ffeb0b90892d71eff4f26227962f5b306d52a55539f1cb2a72993c8252ca518"