aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/qiv
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/qiv')
-rw-r--r--recipes/obsolete/qiv/files/makefile.patch22
-rw-r--r--recipes/obsolete/qiv/qiv_1.9.bb23
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/obsolete/qiv/files/makefile.patch b/recipes/obsolete/qiv/files/makefile.patch
new file mode 100644
index 0000000000..42707be9b9
--- /dev/null
+++ b/recipes/obsolete/qiv/files/makefile.patch
@@ -0,0 +1,22 @@
+--- /tmp/Makefile 2006-09-02 13:04:25.000000000 +0200
++++ qiv-1.9/Makefile 2006-09-02 13:05:05.255780000 +0200
+@@ -4,7 +4,7 @@
+ ######################################################################
+
+ # Directory where qiv will be installed under.
+-PREFIX = /usr/local
++PREFIX = /usr/
+
+ # Font to use for statusbar in fullscreen mode
+ STATUSBAR_FONT = "fixed"
+@@ -53,10 +53,6 @@
+ # Do not edit below here!
+ ######################################################################
+
+-CC = gcc
+-CFLAGS = -O2 -Wall -fomit-frame-pointer -finline-functions \
+- -fcaller-saves -ffast-math -fno-strength-reduce \
+- -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
+
+ INCLUDES = `imlib-config --cflags-gdk`
+ LIBS = `imlib-config --libs-gdk`
diff --git a/recipes/obsolete/qiv/qiv_1.9.bb b/recipes/obsolete/qiv/qiv_1.9.bb
new file mode 100644
index 0000000000..a1b63c6c61
--- /dev/null
+++ b/recipes/obsolete/qiv/qiv_1.9.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Qiv is a very small and pretty fast gdk/Imlib image viewer."
+LICENSE = "GPLv2"
+SECTION = "x11/graphics"
+DEPENDS = "gtk+-1.2 imlib"
+PR = "r1"
+
+SRC_URI = "http://www.klografx.net/qiv/download/qiv-1.9-src.tgz \
+ file://makefile.patch \
+ "
+inherit pkgconfig binconfig
+
+CFLAGS += " -lSM -lICE -lXdmcp"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1/
+
+ install -s -m 0755 qiv ${D}${bindir}/qiv
+ install -m 0644 qiv.1 ${D}${mandir}/man1/qiv.1
+}
+
+SRC_URI[md5sum] = "b368e00543b2b1d9a87b37fd5ba60c57"
+SRC_URI[sha256sum] = "7ffeb0b90892d71eff4f26227962f5b306d52a55539f1cb2a72993c8252ca518"