aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/zd1211/zd1211-r83/makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete/zd1211/zd1211-r83/makefile.patch')
-rw-r--r--recipes/obsolete/zd1211/zd1211-r83/makefile.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/obsolete/zd1211/zd1211-r83/makefile.patch b/recipes/obsolete/zd1211/zd1211-r83/makefile.patch
new file mode 100644
index 0000000000..adc2bd416d
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211-r83/makefile.patch
@@ -0,0 +1,47 @@
+--- zd1211-driver-r83/Makefile.orig 2006-09-02 16:00:00.000000000 +0200
++++ zd1211-driver-r83/Makefile 2006-09-02 16:01:57.000000000 +0200
+@@ -4,10 +4,10 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
+-rM=rm -f -r
++#CC=gcc
++#CPP=g++
++#LD=ld
++#rM=rm -f -r
+
+ VERSION := $(shell uname -r)
+ MODPATH := /lib/modules/$(VERSION)
+@@ -15,14 +15,14 @@
+ # if the kernel is 2.6.x, turn on this
+ KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+ SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++DEFINES ?= -D__KERNEL__ -DMODULE=1
+
+
+
+@@ -228,9 +228,9 @@
+ depmod -a $(VERSION)
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd