aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/python/files/06-libffi-enable-default-mips.patch12
-rw-r--r--recipes/obsolete/python/python-logilab-common/fix-future-in-setup.patch16
-rw-r--r--recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch16
3 files changed, 44 insertions, 0 deletions
diff --git a/recipes/obsolete/python/files/06-libffi-enable-default-mips.patch b/recipes/obsolete/python/files/06-libffi-enable-default-mips.patch
new file mode 100644
index 0000000000..b01f0c751d
--- /dev/null
+++ b/recipes/obsolete/python/files/06-libffi-enable-default-mips.patch
@@ -0,0 +1,12 @@
+Index: Python-2.6.1/Modules/_ctypes/libffi/fficonfig.py.in
+===================================================================
+--- Python-2.6.1.orig/Modules/_ctypes/libffi/fficonfig.py.in
++++ Python-2.6.1/Modules/_ctypes/libffi/fficonfig.py.in
+@@ -5,6 +5,7 @@ src/prep_cif.c
+ ffi_platforms = {
+ 'MIPS_IRIX': ['src/mips/ffi.c', 'src/mips/o32.S', 'src/mips/n32.S'],
+ 'MIPS_LINUX': ['src/mips/ffi.c', 'src/mips/o32.S'],
++ 'MIPS': ['src/mips/ffi.c', 'src/mips/o32.S'],
+ 'X86': ['src/x86/ffi.c', 'src/x86/sysv.S'],
+ 'X86_FREEBSD': ['src/x86/ffi.c', 'src/x86/sysv.S'],
+ 'X86_WIN32': ['src/x86/ffi.c', 'src/x86/win32.S'],
diff --git a/recipes/obsolete/python/python-logilab-common/fix-future-in-setup.patch b/recipes/obsolete/python/python-logilab-common/fix-future-in-setup.patch
new file mode 100644
index 0000000000..1abde49bef
--- /dev/null
+++ b/recipes/obsolete/python/python-logilab-common/fix-future-in-setup.patch
@@ -0,0 +1,16 @@
+Index: common-0.9.3/setup.py
+===================================================================
+--- common-0.9.3.orig/setup.py
++++ common-0.9.3/setup.py
+@@ -17,9 +17,10 @@
+ # 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ """ Generic Setup script, takes package info from __pkginfo__.py file """
+
++from __future__ import nested_scopes
++
+ __revision__ = '$Id: setup.py,v 1.23 2004/05/27 12:07:23 syt Exp $'
+
+-from __future__ import nested_scopes
+ import os
+ import sys
+ import shutil
diff --git a/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch b/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch
new file mode 100644
index 0000000000..c8b7cc805a
--- /dev/null
+++ b/recipes/obsolete/python/python-pydirectfb/fix-directfb-detection.patch
@@ -0,0 +1,16 @@
+Index: pydirectfb/setup.py
+===================================================================
+--- pydirectfb.orig/setup.py
++++ pydirectfb/setup.py
+@@ -11,9 +11,10 @@
+ Check dependencies add add the flags to include_dirs, library_dirs and
+ libraries. The basic logic is taken from pygame.
+ """
+- command = name + '-config --version --cflags --libs 2>/dev/null'
++ command = 'pkg-config %s --modversion --cflags --libs 2>/dev/null' % name
+ try:
+ config = os.popen(command).readlines()
++ print config
+ if len(config) == 0:
+ raise ValueError, 'command not found'
+ flags = (' '.join(config[1:]) + ' ').split()