aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/images/nylon-image-base.bb39
-rw-r--r--recipes/obsolete/images/nylon-image-extended.bb84
-rw-r--r--recipes/obsolete/images/nylon-image-extra.bb9
-rw-r--r--recipes/obsolete/images/nylon-image-mini.bb14
-rw-r--r--recipes/obsolete/images/nylon-image-standard.bb26
-rw-r--r--recipes/obsolete/meta/nylon-feed.bb46
-rw-r--r--recipes/obsolete/meta/nylon-feed.inc71
7 files changed, 289 insertions, 0 deletions
diff --git a/recipes/obsolete/images/nylon-image-base.bb b/recipes/obsolete/images/nylon-image-base.bb
new file mode 100644
index 0000000000..416be1fae5
--- /dev/null
+++ b/recipes/obsolete/images/nylon-image-base.bb
@@ -0,0 +1,39 @@
+inherit image
+inherit nylon-image
+
+IMAGE_FSTYPES = "jffs2 tar.gz"
+
+export IMAGE_BASENAME = "nylon-base"
+
+NYLON_BASE = "base-files base-passwd bash busybox \
+ ipkg initscripts less \
+ madwifi-modules \
+ mtd-utils \
+ nylon-scripts \
+ nano ncurses netbase \
+ openssh \
+ pciutils \
+ sysvinit \
+ tinylogin \
+ tzdata \
+ wireless-tools wlan-ng-utils"
+
+DEPENDS += "virtual/kernel less nano"
+
+## kernel 2.4 ##
+NYLON_IMAGE_RDEPENDS_mtx-1 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
+NYLON_IMAGE_RDEPENDS_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
+## kernel 2.6 ##
+NYLON_IMAGE_RDEPENDS_mtx-3 = " module-init-tools udev"
+NYLON_IMAGE_RDEPENDS_mtx-3a = " module-init-tools"
+
+RDEPENDS_append = ${NYLON_IMAGE_RDEPENDS}
+
+IMAGE_INSTALL = "kernel less nano elvis-tiny \
+ ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS} ${NYLON_IMAGE_RDEPENDS}"
+
+IMAGE_LINGUAS = ""
+
+# we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND = "rm -f ${IMAGE_ROOTFS}/tmp/*Image*"
+# needed?? the above line is the same as in classes/nylon-image.bbclass
diff --git a/recipes/obsolete/images/nylon-image-extended.bb b/recipes/obsolete/images/nylon-image-extended.bb
new file mode 100644
index 0000000000..4fb324d52f
--- /dev/null
+++ b/recipes/obsolete/images/nylon-image-extended.bb
@@ -0,0 +1,84 @@
+require nylon-image-base.bb
+require ../meta/nylon-feed.inc
+
+export IMAGE_BASENAME = "nylon-extended"
+
+NYLON_EXTENDED_DEPENDS = "${NYLON_FEED}"
+
+NYLON_EXTENDED_RDEPENDS = "\
+ hostap-modules-cs \
+ hostap-modules-pci \
+ modutils-depmod \
+ modutils-initscripts \
+ modutils-modinfo \
+ ntpdate \
+ ntp-bin \
+ ntp-tickadj \
+ openssh-scp \
+ openssh-ssh \
+ openssh-sshd \
+ perl-misc \
+ perl-module-autoloader \
+ perl-module-base \
+ perl-module-bytes \
+ perl-module-carp \
+ perl-module-config \
+ perl-module-constant \
+ perl-module-data-dumper \
+ perl-module-encode \
+ perl-module-encode-alias \
+ perl-module-encode-config \
+ perl-module-encode-encoding \
+ perl-module-encode-unicode \
+ perl-module-errno \
+ perl-module-exporter \
+ perl-module-exporter-heavy \
+ perl-module-fields \
+ perl-module-getopt-long \
+ perl-module-integer \
+ perl-module-io \
+ perl-module-io-handle \
+ perl-module-io-socket \
+ perl-module-io-socket-inet \
+ perl-module-io-socket-unix \
+ perl-module-locale \
+ perl-module-overload \
+ perl-module-posix \
+ perl-module-selectsaver \
+ perl-module-socket \
+ perl-module-strict \
+ perl-module-symbol \
+ perl-module-sys-hostname \
+ perl-module-vars \
+ perl-module-warnings \
+ perl-module-warnings-register \
+ perl-module-xsloader \
+"
+
+KERNEL_MODULES = " \
+ kernel-module-aes \
+ kernel-module-bridge \
+ kernel-module-ds \
+ kernel-module-fat \
+ kernel-module-mii \
+ kernel-module-scsi-mod \
+ kernel-module-sd-mod \
+ kernel-module-usb-storage \
+ kernel-module-usb-ohci \
+ kernel-module-usbnet \
+ kernel-module-usbserial \
+ kernel-module-vfat \
+ kernel-module-yenta-socket \
+"
+
+
+DEPENDS += "${NYLON_EXTENDED_DEPENDS}"
+
+IMAGE_INSTALL += "${NYLON_EXTENDED_DEPENDS} ${KERNEL_MODULES} \
+ ${NYLON_EXTENDED_RDEPENDS} elvis-tools"
+
+IMAGE_INSTALL_append_mtx-1 = "\
+ kernel-module-au1x00-bi \
+ kernel-module-network-fd \
+ kernel-module-usbdcore"
+# kernel-module-usbdprocfs \
diff --git a/recipes/obsolete/images/nylon-image-extra.bb b/recipes/obsolete/images/nylon-image-extra.bb
new file mode 100644
index 0000000000..e943a98fc0
--- /dev/null
+++ b/recipes/obsolete/images/nylon-image-extra.bb
@@ -0,0 +1,9 @@
+require nylon-image-standard.bb
+
+export IMAGE_BASENAME = "nylon-extra"
+
+IMAGE_INSTALL = "\
+ kismet \
+ netperf \
+ nylon-statistics \
+ openvpn"
diff --git a/recipes/obsolete/images/nylon-image-mini.bb b/recipes/obsolete/images/nylon-image-mini.bb
new file mode 100644
index 0000000000..f011cb171c
--- /dev/null
+++ b/recipes/obsolete/images/nylon-image-mini.bb
@@ -0,0 +1,14 @@
+export IMAGE_BASENAME = "nylon-mini"
+
+inherit image
+
+NYLON_BASE = "base-files base-passwd busybox \
+ dropbear \
+ miniinit \
+ modutils-collateral \
+ modutils-initscripts \
+ netbase \
+ wireless-tools"
+
+IMAGE_INSTALL += "kernel ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
+IMAGE_LINGUAS = ""
diff --git a/recipes/obsolete/images/nylon-image-standard.bb b/recipes/obsolete/images/nylon-image-standard.bb
new file mode 100644
index 0000000000..9238b0f8b2
--- /dev/null
+++ b/recipes/obsolete/images/nylon-image-standard.bb
@@ -0,0 +1,26 @@
+require nylon-image-base.bb
+
+export IMAGE_BASENAME = "nylon-standard"
+
+NYLON_STANDARD = "\
+ dash \
+ dnsmasq \
+ hostap-daemon hostap-utils \
+ linux-hotplug \
+ ifplugd \
+ iproute2 \
+ madwifi-modules \
+ nylon-config \
+ olsrd \
+ ppp \
+ rp-pppoe \
+ simple-firewall \
+ tcpdump \
+ wpa-supplicant \
+ yamonenv"
+
+DEPENDS += "hostap-modules ntp \
+ ${NYLON_STANDARD}"
+
+IMAGE_INSTALL += "hostap-modules-pci ntpdate less nano elvis-tiny \
+ ${NYLON_STANDARD}"
diff --git a/recipes/obsolete/meta/nylon-feed.bb b/recipes/obsolete/meta/nylon-feed.bb
new file mode 100644
index 0000000000..d68f5f8cab
--- /dev/null
+++ b/recipes/obsolete/meta/nylon-feed.bb
@@ -0,0 +1,46 @@
+LICENSE = "MIT"
+
+include nylon-feed.inc
+RDEPENDS = "${NYLON_FEED} \
+ boost \
+ db3 \
+ dhcp \
+ dhcp-forwarder \
+ expat \
+ glib-2.0 \
+ glibc \
+ gmp \
+ iproute2 \
+ libcgicc \
+ libedit \
+ libmail-sendmail-perl \
+ libnetserver-generic-perl \
+ libpcre \
+ lzo \
+ make \
+ mystun-server \
+ mc \
+ net-snmp \
+ openssl \
+ openswan \
+ openvpn \
+ python \
+ ppp-dsl \
+ rp-pppoe \
+ simple-firewall \
+ thttpd \
+ wget \
+ wlan-ng-modules \
+ zlib \
+"
+
+# vsftpd \
+#
+
+do_index() {
+ touch ${DEPLOY_DIR_IPK}/Packages
+ opkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
+}
+
+addtask index before do_build after do_install
+
diff --git a/recipes/obsolete/meta/nylon-feed.inc b/recipes/obsolete/meta/nylon-feed.inc
new file mode 100644
index 0000000000..15f0b20881
--- /dev/null
+++ b/recipes/obsolete/meta/nylon-feed.inc
@@ -0,0 +1,71 @@
+NYLON_FEED = " \
+base-files \
+bash \
+binutils \
+bridge-utils \
+busybox \
+chillispot \
+dash \
+ddclient \
+dnsmasq \
+elvis \
+gdb \
+gnupg \
+hostap-modules \
+hostap-utils \
+hostap-daemon \
+htb-init \
+ifplugd \
+initscripts \
+iperf \
+ipkg \
+iptables \
+ksymoops \
+less \
+linux-hotplug \
+lsof \
+madwifi-modules \
+maradns \
+minicom \
+mobilemesh \
+modutils \
+mtd-utils \
+mtr \
+nano \
+ncurses \
+netbase \
+netperf \
+ntp \
+nylon-config \
+nylon-scripts \
+nylon-statistics \
+olsrd \
+openssh \
+pciutils \
+pcmcia-cs \
+perl \
+pmacct \
+ppp \
+pptp-linux \
+rrdtool \
+ser \
+simple-firewall \
+stunnel \
+sysvinit \
+tcl \
+tcpdump \
+tinc \
+tzdata \
+vtun \
+wireless-tools \
+wpa-supplicant \
+yamonenv \
+"
+
+# TODO:
+# strace: SYS_read?
+# gdb-cross: install paths, sdk?
+# screen: sgttyb?
+
+#kismet \
+#