aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ode/files/install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ode/files/install.patch')
-rw-r--r--recipes/ode/files/install.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/ode/files/install.patch b/recipes/ode/files/install.patch
new file mode 100644
index 0000000000..d63229f8ec
--- /dev/null
+++ b/recipes/ode/files/install.patch
@@ -0,0 +1,22 @@
+Index: ode-0.9/Makefile.am
+===================================================================
+--- ode-0.9.orig/Makefile.am
++++ ode-0.9/Makefile.am
+@@ -25,13 +25,13 @@ dist-zip: ${PACKAGE}-${VERSION}.tar.gz
+
+ if USE_SONAME
+ install-exec-hook:
+- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(libdir)/libode.so
+- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(libdir)/@ODE_SONAME@
+- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(libdir)/@ODE_SONAME@.@ODE_REVISION@
+- /sbin/ldconfig
++ echo /sbin/ldconfig
+ else
+ install-exec-hook:
+ endif