aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/oneko/oneko_1.2.sakura.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/oneko/oneko_1.2.sakura.5.bb')
-rw-r--r--recipes/oneko/oneko_1.2.sakura.5.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/oneko/oneko_1.2.sakura.5.bb b/recipes/oneko/oneko_1.2.sakura.5.bb
new file mode 100644
index 0000000000..efec192cc6
--- /dev/null
+++ b/recipes/oneko/oneko_1.2.sakura.5.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Small cat chasing mouse cursor"
+AUTHOR = "Tatsuya Kato"
+HOMEPAGE = "http://www.daidouji.com/oneko/"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+LICENSE = "PD"
+DEPENDS = "virtual/libx11 libxext"
+
+SRC_URI = "http://www.daidouji.com/oneko/distfiles/oneko-${PV}.tar.gz \
+ file://oneko.desktop \
+ file://kill-oneko.desktop \
+ file://oneko.png \
+ file://kill-oneko.png \
+ file://remove-bsd-daemon-logo.patch;patch=1"
+
+inherit pkgconfig
+
+do_compile() {
+ ${CC} oneko.c -o oneko -lm `pkg-config --cflags --libs x11 xext` \
+ -DSHAPE
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -d ${D}/${mandir}/man6
+ install -m 0755 ${S}/oneko ${D}/${bindir}
+ install -m 0644 ${WORKDIR}/*oneko.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/*oneko.desktop ${D}/${datadir}/applications
+ install -m 0644 ${S}/oneko.man ${D}/${mandir}/man6/oneko.6
+}
+
+
+