aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openal
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openal')
-rw-r--r--recipes/openal/files/void-workaround.patch13
-rw-r--r--recipes/openal/openal_0.0.8.bb24
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/openal/files/void-workaround.patch b/recipes/openal/files/void-workaround.patch
new file mode 100644
index 0000000000..c2698a95bb
--- /dev/null
+++ b/recipes/openal/files/void-workaround.patch
@@ -0,0 +1,13 @@
+Index: openal-0.0.8/common/include/AL/alc.h
+===================================================================
+--- openal-0.0.8.orig/common/include/AL/alc.h 2007-09-22 19:40:47.000000000 +0200
++++ openal-0.0.8/common/include/AL/alc.h 2007-09-22 19:41:04.000000000 +0200
+@@ -82,7 +82,7 @@
+ typedef double ALCdouble;
+
+ /** void type (for opaque pointers only) */
+-typedef void ALCvoid;
++#define ALCvoid void
+
+
+ /* Enumerant values begin at column 50. No tabs. */
diff --git a/recipes/openal/openal_0.0.8.bb b/recipes/openal/openal_0.0.8.bb
new file mode 100644
index 0000000000..280c5d75e8
--- /dev/null
+++ b/recipes/openal/openal_0.0.8.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "OpenAL is a cross-platform 3D audio API."
+DEPENDS = "alsa-lib virtual/libsdl libvorbis"
+
+SRC_URI = "http://www.openal.org/openal_webstf/downloads/${PN}-${PV}.tar.gz \
+ file://void-workaround.patch"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-alsa --enable-sdl --enable-vorbis --disable-mp3 \
+ --disable-smpeg --disable-arts"
+
+do_configure_append () {
+ sed -i "s/@requirements@/alsa vorbis/" admin/pkgconfig/openal.pc
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libopenal"
+
+FILES_libopenal += "${libdir}/libopenal.so.*"
+FILES_openal-dev += "${bindir}/openal-config"
+FILES_openal = ""