aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openbabel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openbabel')
-rw-r--r--recipes/openbabel/openbabel_2.2.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/openbabel/openbabel_2.2.0.bb b/recipes/openbabel/openbabel_2.2.0.bb
new file mode 100644
index 0000000000..0ae1c50a57
--- /dev/null
+++ b/recipes/openbabel/openbabel_2.2.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Open Babel is a chemical toolbox designed to speak the many languages of chemical data."
+LICENSE = "GPLv2"
+DEPENDS = "libxml2 boost"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openbabel/openbabel-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = " --disable-xmltest "
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dbg += "${libdir}/openbabel/*/.debug"
+FILES_${PN}-dev += "${libdir}/openbabel/*/*.la"
+
+