summaryrefslogtreecommitdiffstats
path: root/recipes/openjade/openjade_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openjade/openjade_1.3.2.bb')
-rw-r--r--recipes/openjade/openjade_1.3.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/openjade/openjade_1.3.2.bb b/recipes/openjade/openjade_1.3.2.bb
new file mode 100644
index 0000000000..dcbfd886a0
--- /dev/null
+++ b/recipes/openjade/openjade_1.3.2.bb
@@ -0,0 +1,30 @@
+SECTION = "unknown"
+DEPENDS = "opensp"
+RDEPENDS = "sgml-common"
+DESCRIPTION = "OpenJade is a suite of tools for validating, \
+processing, and applying DSSSL (Document Style Semantics and \
+Specification Language) stylesheets to SGML and XML documents."
+LICENSE = "BSD"
+SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
+ --enable-splibdir=${STAGING_LIBDIR}"
+
+acpaths = "-I ${S}/config"
+
+# Trailing whitespace is important. Otherwise compiler arguments will be messed
+# up, resulting in a fail in do_configure.
+CFLAGS_prepend = "-I${S}/include "
+
+do_configure_prepend () {
+ mv config/configure.in .
+}
+
+do_stage () {
+ oe_libinstall -a -so -C style libostyle ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C spgrove libospgrove ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C grove libogrove ${STAGING_LIBDIR}
+}