aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb')
-rw-r--r--recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb b/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb
new file mode 100644
index 0000000000..5cb7042c92
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Standard Gtk+ theme for the Openmoko distribution, qvga version"
+SECTION = "openmoko/base"
+PV = "0.0+svnr${SRCREV}"
+PR = "r0"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=themes;proto=http"
+S = "${WORKDIR}"
+
+dirs = "themes/openmoko-standard-qvga"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/themes/
+ for i in ${dirs}; do
+ cp -fpPR ${WORKDIR}/$i ${D}${datadir}/themes/
+ done
+
+ install -d ${D}${sysconfdir}/gtk-2.0
+ echo 'include "${datadir}/themes/openmoko-standard-qvga/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir} ${sysconfdir}"