aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-projects/tichy_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-projects/tichy_git.bb')
-rw-r--r--recipes/openmoko-projects/tichy_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/openmoko-projects/tichy_git.bb b/recipes/openmoko-projects/tichy_git.bb
new file mode 100644
index 0000000000..4a1ffb500e
--- /dev/null
+++ b/recipes/openmoko-projects/tichy_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python applets manager"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS += "python-pygame virtual/libsdl libsdl-image python-dbus python-pygobject"
+PV = "0.2+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.openmoko.org/git/tichy.git;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "python-pygame"
+# This is because pkg-config --libs --cflags sdl doesn't return the correct path (bug in libsdl recipe ?)
+CFLAGS += -I${STAGING_INCDIR}/SDL