aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-tools/app-restarter_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-tools/app-restarter_svn.bb')
-rw-r--r--recipes/openmoko-tools/app-restarter_svn.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/openmoko-tools/app-restarter_svn.bb b/recipes/openmoko-tools/app-restarter_svn.bb
new file mode 100644
index 0000000000..61b68b5173
--- /dev/null
+++ b/recipes/openmoko-tools/app-restarter_svn.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Small utility to restart a crashing application"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=app_restarter;proto=http"
+S = "${WORKDIR}/app_restarter"
+PV = "1.0+svnr${SRCREV}"
+PE = "2"
+
+inherit pkgconfig
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/app_restarter ${D}/${bindir}/${PN}
+}