aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko2/libmokoui2/makefile.am.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko2/libmokoui2/makefile.am.patch')
-rw-r--r--recipes/openmoko2/libmokoui2/makefile.am.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/openmoko2/libmokoui2/makefile.am.patch b/recipes/openmoko2/libmokoui2/makefile.am.patch
new file mode 100644
index 0000000000..79f0a48361
--- /dev/null
+++ b/recipes/openmoko2/libmokoui2/makefile.am.patch
@@ -0,0 +1,19 @@
+--- libmokoui.old/bindings/python/Makefile.am 2009-06-10 12:42:32.000000000 +0200
++++ libmokoui2/bindings/python/Makefile.am 2009-06-10 12:51:45.000000000 +0200
+@@ -1,13 +1,12 @@
+-
+-PY_DEFS=`pkg-config --variable=defsdir pygtk-2.0`
+-PYTHON_INCLUDES=-I/usr/include/python${PYTHON_VERSION}
++PY_DEFS=${PKG_CONFIG_SYSROOT_DIR}`pkg-config --variable=defsdir pygtk-2.0`
++PYTHON_INCLUDES=-I${PKG_CONFIG_SYSROOT_DIR}/usr/include/python${PYTHON_VERSION}
+
+ CLEANFILES = \
+ mokoui.defs \
+ mokoui.c
+
+ mokoui.defs: ../../libmokoui/moko-finger-scroll.h
+- python /usr/share/pygtk/2.0/codegen/h2def.py ../../libmokoui/moko-finger-scroll.h > mokoui.defs
++ python ${PKG_CONFIG_SYSROOT_DIR}`pkg-config --variable=codegendir pygtk-2.0`/h2def.py ../../libmokoui/moko-finger-scroll.h > mokoui.defs
+
+ mokoui.c: mokoui.defs mokoui.override
+ pygtk-codegen-2.0 --prefix mokoui \