summaryrefslogtreecommitdiffstats
path: root/recipes/openobex/openobex_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openobex/openobex_1.3.bb')
-rw-r--r--recipes/openobex/openobex_1.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/openobex/openobex_1.3.bb b/recipes/openobex/openobex_1.3.bb
new file mode 100644
index 0000000000..65e98e4ab1
--- /dev/null
+++ b/recipes/openobex/openobex_1.3.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez-libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_stage() {
+ autotools_stage_all
+}
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"