aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssh/openssh_3.7.1p2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openssh/openssh_3.7.1p2.bb')
-rw-r--r--recipes/openssh/openssh_3.7.1p2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/openssh/openssh_3.7.1p2.bb b/recipes/openssh/openssh_3.7.1p2.bb
new file mode 100644
index 0000000000..99083bb796
--- /dev/null
+++ b/recipes/openssh/openssh_3.7.1p2.bb
@@ -0,0 +1,37 @@
+DEPENDS = "zlib openssl"
+SECTION = "console/network"
+DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
+Ssh (Secure Shell) is a program for logging into a remote machine \
+and for executing commands on a remote machine. \
+It provides secure encrypted communications between two untrusted \
+hosts over an insecure network. X11 connections and arbitrary TCP/IP \
+ports can also be forwarded over the secure channel. \
+It is intended as a replacement for rlogin, rsh and rcp, and can be \
+used to provide applications with a secure communication channel."
+
+SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://scp-nossl.patch;patch=1 \
+ file://sshd_config"
+
+inherit autotools
+LICENSE = "openssh"
+sysconfdir_append = "/ssh"
+export ASKPASS_PROGRAM = "${bindir}/ssh-askpass"
+export LD = "${CC}"
+CFLAGS_prepend = "-I${S} "
+CFLAGS_append = " -D__FILE_OFFSET_BITS=64"
+LDFLAGS_prepend = "-L${S} -L${S}/openbsd-compat "
+EXTRA_OECONF = "--disable-suid-ssh --with-ssl=${STAGING_LIBDIR}/ssl \
+ --with-rand-helper=no --without-pam"
+EXTRA_OEMAKE = "'STRIP_OPT='"
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_compile_append () {
+ install -m 0644 ${WORKDIR}/sshd_config ${S}/
+}