aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl/openssl-native_1.0.0a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openssl/openssl-native_1.0.0a.bb')
-rw-r--r--recipes/openssl/openssl-native_1.0.0a.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/openssl/openssl-native_1.0.0a.bb b/recipes/openssl/openssl-native_1.0.0a.bb
new file mode 100644
index 0000000000..bb471b0ee2
--- /dev/null
+++ b/recipes/openssl/openssl-native_1.0.0a.bb
@@ -0,0 +1,27 @@
+require openssl.inc
+
+inherit pkgconfig native
+
+SRC_URI[src.md5sum] = "e3873edfffc783624cfbdb65e2249cbd"
+SRC_URI[src.sha256sum] = "18a9bd1fc02b8ef90dded34fafaa9089baaafef278a19fc4e89c2ab0dcf70f63"
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+export DIRS = "crypto ssl apps engines"
+
+# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
+export FULL_OPTIMIZATION = " "
+export BUILD_OPTIMIZATION = " "
+
+SRC_URI += "file://configure-targets.patch \
+ file://shared-libs.patch \
+ file://debian.patch \
+ file://libdeps-first.patch \
+ "
+
+PARALLEL_MAKE = ""
+
+CFLAG += " -Wa,--noexecstack "
+
+NATIVE_INSTALL_WORKS = "1"