summaryrefslogtreecommitdiffstats
path: root/recipes/openssl/openssl-native_1.0.0b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openssl/openssl-native_1.0.0b.bb')
-rw-r--r--recipes/openssl/openssl-native_1.0.0b.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/openssl/openssl-native_1.0.0b.bb b/recipes/openssl/openssl-native_1.0.0b.bb
new file mode 100644
index 0000000000..4ad4936b20
--- /dev/null
+++ b/recipes/openssl/openssl-native_1.0.0b.bb
@@ -0,0 +1,27 @@
+require openssl.inc
+
+inherit pkgconfig native
+
+SRC_URI[src.md5sum] = "104deb3b7e6820cae6de3f49ba0ff2b0"
+SRC_URI[src.sha256sum] = "4e7b4e2fb33ee2d97c5e143561ab495dbbfc08f0a863e617a0c7adca19017331"
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+export DIRS = "crypto ssl apps engines"
+
+# This flag can contain target options (e.g -mfpu=neon for armv7-a systems)
+export FULL_OPTIMIZATION = " "
+export BUILD_OPTIMIZATION = " "
+
+SRC_URI += "file://configure-targets.patch \
+ file://shared-libs.patch \
+ file://debian.patch \
+ file://libdeps-first.patch \
+ "
+
+PARALLEL_MAKE = ""
+
+CFLAG += " -Wa,--noexecstack "
+
+NATIVE_INSTALL_WORKS = "1"