aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openttd/openttd_0.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openttd/openttd_0.7.4.bb')
-rw-r--r--recipes/openttd/openttd_0.7.4.bb44
1 files changed, 2 insertions, 42 deletions
diff --git a/recipes/openttd/openttd_0.7.4.bb b/recipes/openttd/openttd_0.7.4.bb
index a286135c18..d59eb6fa9c 100644
--- a/recipes/openttd/openttd_0.7.4.bb
+++ b/recipes/openttd/openttd_0.7.4.bb
@@ -1,53 +1,13 @@
-DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition."
-HOMEPAGE = "http://www.openttd.org"
-LICENSE = "GPLv2"
-DEPENDS = "libsdl-net libpng zlib freetype fontconfig"
-RRECOMMENDS_${PN} = "openttd-gfx openttd-sfx"
-PR = "r1"
+require openttd.inc
-inherit siteinfo sdl
+PR = "r2"
-SRC_URI ="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2 "
SRC_URI_append_shr = " file://openttd.cfg"
-APPIMAGE = "media/openttd.128.png"
-
-do_configure() {
- # The way the OTTD configure system handles the application's directories
- # isn't the way autotools does it. Mainly prefix is always prepended even if
- # absolute binary-dir and data-dir is given.
-
- ${S}/configure \
- --host=${TARGET_SYS} \
- --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
- --os=UNIX \
- --endian=${SITEINFO_ENDIANNESS} \
- --prefix-dir=${prefix} \
- --binary-dir=bin \
- --with-midi=/bin/true \
- --with-zlib=${STAGING_LIBDIR} \
- --with-png \
- --with-freetype \
- --without-icu \
- --without-allegro \
- --cc-build=gcc \
- --cc-host=${TARGET_SYS}-gcc \
- --cxx-build=g++ \
- --cxx-host=${TARGET_SYS}-g++ \
- --strip=${TARGET_SYS}-strip \
- --install-dir=${D}
-}
-
-do_install() {
- oe_runmake install
-}
-
do_install_append_shr() {
install -d ${D}${datadir}/games/openttd/data/
install -m 0644 ${WORKDIR}/openttd.cfg ${D}${datadir}/games/openttd/data/
}
-FILES_${PN} += "${datadir}"
-
SRC_URI[md5sum] = "30763b0dc6d77386a23261ad4b2cded8"
SRC_URI[sha256sum] = "014286af4b978fec3845fe276d40d07789acd4ac67b5f489f9bdfdf0eed6ad27"