summaryrefslogtreecommitdiffstats
path: root/recipes/openttd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openttd')
-rw-r--r--recipes/openttd/files/openttd_0.6.3-buildfix.patch25
-rw-r--r--recipes/openttd/openttd.inc48
-rw-r--r--recipes/openttd/openttd_0.6.3.bb9
3 files changed, 82 insertions, 0 deletions
diff --git a/recipes/openttd/files/openttd_0.6.3-buildfix.patch b/recipes/openttd/files/openttd_0.6.3-buildfix.patch
new file mode 100644
index 0000000000..c0ac8f1945
--- /dev/null
+++ b/recipes/openttd/files/openttd_0.6.3-buildfix.patch
@@ -0,0 +1,25 @@
+Index: openttd-0.6.3/config.lib
+===================================================================
+--- openttd-0.6.3.orig/config.lib 2008-10-01 19:00:50.000000000 +0200
++++ openttd-0.6.3/config.lib 2008-12-04 19:04:29.000000000 +0100
+@@ -1341,7 +1341,7 @@
+ if [ -z "$6" ]; then
+ compiler="$3"
+ else
+- compiler="$3-$6"
++ compiler="$4"
+ fi
+ machine=`eval $compiler $9 2>/dev/null`
+ ret=$?
+@@ -1357,11 +1357,6 @@
+ exit 1
+ fi
+
+- if [ "$machine" != "$3" ] && ( [ "$8" = "0" ] || [ "$8" = "1" ] ); then
+- log 1 "checking $1... expected $3, found $machine"
+- log 1 "the compiler suggests it doesn't build code for the machine you specified"
+- exit 1
+- fi
+ elif [ -n "$4" ]; then
+ # Check for manual compiler
+ machine=`$4 $9 2>/dev/null`
diff --git a/recipes/openttd/openttd.inc b/recipes/openttd/openttd.inc
new file mode 100644
index 0000000000..b1a5e956d7
--- /dev/null
+++ b/recipes/openttd/openttd.inc
@@ -0,0 +1,48 @@
+# Note: OpenTTD's build system changed considerably in 0.6.x
+# This include file is written towards the newer versions.
+
+DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition. \
+This package provides the engine only. You will need to get the data file elsewhere \
+through official channels."
+HOMEPAGE = "http://openttd.sf.net"
+LICENSE = "GPLv2"
+
+DEPENDS = "libsdl-net libpng zlib freetype fontconfig"
+
+SRC_URI = "http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2"
+
+APPIMAGE = "media/openttd.48.png"
+
+inherit siteinfo sdl
+
+do_configure() {
+ # The way the OTTD configure system handles the application's directories
+ # isn't the way autotools does it. Mainly prefix is always prepended even if
+ # absolute binary-dir and data-dir is given. Sigh ...
+
+ # Disabling MIDI feature for now.
+ ./configure \
+ --build=${BUILD_SYS} \
+ --host=${TARGET_SYS} \
+ --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
+ --os=UNIX \
+ --endian=${SITEINFO_ENDIANESS} \
+ --prefix-dir=${prefix} \
+ --binary-dir=bin \
+ --with-midi=/bin/true \
+ --with-zlib=${STAGING_LIBDIR} \
+ --with-png \
+ --with-freetype \
+ --cc-build=gcc \
+ --cc-host=${TARGET_SYS}-gcc \
+ --cxx-build=g++ \
+ --cxx-host=${TARGET_SYS}-g++ \
+ --strip=${TARGET_SYS}-strip \
+ --install-dir=${D}
+}
+
+do_install() {
+ oe_runmake install
+}
+
+FILES_${PN} += "${datadir}/*"
diff --git a/recipes/openttd/openttd_0.6.3.bb b/recipes/openttd/openttd_0.6.3.bb
new file mode 100644
index 0000000000..a8a06738f4
--- /dev/null
+++ b/recipes/openttd/openttd_0.6.3.bb
@@ -0,0 +1,9 @@
+require openttd.inc
+
+PR = "r0"
+
+# When upgrading this recipe make sure to refresh this patch.
+SRC_URI += "file://openttd_${PV}-buildfix.patch;patch=1"
+
+
+