aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openvz
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openvz')
-rw-r--r--recipes/openvz/vzctl/vzctl-add-arm-syscalls.patch23
-rw-r--r--recipes/openvz/vzctl_3.0.23.bb12
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/openvz/vzctl/vzctl-add-arm-syscalls.patch b/recipes/openvz/vzctl/vzctl-add-arm-syscalls.patch
new file mode 100644
index 0000000000..7ade3775aa
--- /dev/null
+++ b/recipes/openvz/vzctl/vzctl-add-arm-syscalls.patch
@@ -0,0 +1,23 @@
+diff --git a/include/vzsyscalls.h b/include/vzsyscalls.h
+index 55a4c28..34ea544 100644
+--- a/include/vzsyscalls.h
++++ b/include/vzsyscalls.h
+@@ -52,6 +52,18 @@
+ #else
+ #define __NR_ioprio_set 289
+ #endif
++#elif __arm__
++#define __NR_fairsched_vcpus (__NR_SYSCALL_BASE+370)
++#define __NR_fairsched_mknod (__NR_SYSCALL_BASE+371)
++#define __NR_fairsched_rmnod (__NR_SYSCALL_BASE+372)
++#define __NR_fairsched_chwt (__NR_SYSCALL_BASE+373)
++#define __NR_fairsched_mvpr (__NR_SYSCALL_BASE+374)
++#define __NR_fairsched_rate (__NR_SYSCALL_BASE+375)
++#define __NR_setluid (__NR_SYSCALL_BASE+377)
++#define __NR_setublimit (__NR_SYSCALL_BASE+378)
++#ifndef __NR_ioprio_set
++#define __NR_ioprio_set (__NR_SYSCALL_BASE+314)
++#endif
+ #else
+ #error "no syscall for this arch"
+ #endif
diff --git a/recipes/openvz/vzctl_3.0.23.bb b/recipes/openvz/vzctl_3.0.23.bb
new file mode 100644
index 0000000000..f76b6e2503
--- /dev/null
+++ b/recipes/openvz/vzctl_3.0.23.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "An utility to manage OpenVZ containers"
+LICENSE = "GPLv2"
+
+RDEPENDS = "bash gawk sed grep coreutils tar"
+
+SRC_URI = "http://download.openvz.org/utils/vzctl/${PV}/src/vzctl-${PV}.tar.bz2 \
+ file://vzctl-add-arm-syscalls.patch;patch=1 \
+ "
+
+inherit autotools
+
+FILES_${PN} += " ${libdir}/${PN}/lib*.so*"