aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-help-en
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opie-help-en')
-rw-r--r--recipes/opie-help-en/opie-help-en.inc27
-rw-r--r--recipes/opie-help-en/opie-help-en_1.2.2.bb7
-rw-r--r--recipes/opie-help-en/opie-help-en_1.2.3.bb4
-rw-r--r--recipes/opie-help-en/opie-help-en_1.2.4.bb4
-rw-r--r--recipes/opie-help-en/opie-help-en_cvs.bb6
5 files changed, 48 insertions, 0 deletions
diff --git a/recipes/opie-help-en/opie-help-en.inc b/recipes/opie-help-en/opie-help-en.inc
new file mode 100644
index 0000000000..1b110f9d30
--- /dev/null
+++ b/recipes/opie-help-en/opie-help-en.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Opie Help Packages - English"
+SECTION = "opie/help"
+PRIORITY = "optional"
+LICENSE = "GPL"
+ALLOW_EMPTY = "1"
+PACKAGE_ARCH = "all"
+
+PACKAGES += "${PN}"
+RDEPENDS_${PN} = "opie-helpbrowser"
+
+S = "${WORKDIR}/html"
+
+do_install() {
+ install -d ${D}${palmtopdir}/help/en/html/
+ install -m 0644 ${WORKDIR}/html/*.html ${D}${palmtopdir}/help/en/html/
+ for d in $(find . -type d | grep -v "CVS\|patch")
+ do
+ install -d ${D}${palmtopdir}/help/en/html/$d
+ install -m 0644 ${WORKDIR}/html/$d/*.html ${D}${palmtopdir}/help/en/html/$d/
+ done
+}
+
+python populate_packages_prepend () {
+ help_dir = bb.data.expand('${palmtopdir}/help/en/html/', d)
+
+ do_split_packages(d, help_dir, file_regex='^(.*)\.html$', output_pattern='opie-%s-help-en', description='Opie Help for %s - English', aux_files_pattern=help_dir + '%s/*')
+}
diff --git a/recipes/opie-help-en/opie-help-en_1.2.2.bb b/recipes/opie-help-en/opie-help-en_1.2.2.bb
new file mode 100644
index 0000000000..f1b3dc5f47
--- /dev/null
+++ b/recipes/opie-help-en/opie-help-en_1.2.2.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PR = "r1"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/help/en/html"
diff --git a/recipes/opie-help-en/opie-help-en_1.2.3.bb b/recipes/opie-help-en/opie-help-en_1.2.3.bb
new file mode 100644
index 0000000000..b07babb527
--- /dev/null
+++ b/recipes/opie-help-en/opie-help-en_1.2.3.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/help/en/html "
diff --git a/recipes/opie-help-en/opie-help-en_1.2.4.bb b/recipes/opie-help-en/opie-help-en_1.2.4.bb
new file mode 100644
index 0000000000..b07babb527
--- /dev/null
+++ b/recipes/opie-help-en/opie-help-en_1.2.4.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/help/en/html "
diff --git a/recipes/opie-help-en/opie-help-en_cvs.bb b/recipes/opie-help-en/opie-help-en_cvs.bb
new file mode 100644
index 0000000000..5960820a18
--- /dev/null
+++ b/recipes/opie-help-en/opie-help-en_cvs.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+PR = "r1"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/help/en/html "