aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-qcop
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opie-qcop')
-rw-r--r--recipes/opie-qcop/files/unbreak-logging.patch16
-rw-r--r--recipes/opie-qcop/opie-qcop.inc13
-rw-r--r--recipes/opie-qcop/opie-qcop_1.2.2.bb5
-rw-r--r--recipes/opie-qcop/opie-qcop_1.2.3.bb6
-rw-r--r--recipes/opie-qcop/opie-qcop_1.2.4.bb6
-rw-r--r--recipes/opie-qcop/opie-qcop_cvs.bb7
6 files changed, 53 insertions, 0 deletions
diff --git a/recipes/opie-qcop/files/unbreak-logging.patch b/recipes/opie-qcop/files/unbreak-logging.patch
new file mode 100644
index 0000000000..d2b5228b26
--- /dev/null
+++ b/recipes/opie-qcop/files/unbreak-logging.patch
@@ -0,0 +1,16 @@
+Index: opie/core/apps/qcop/qcopimpl.cpp
+===================================================================
+RCS file: /cvs/opie/core/apps/qcop/qcopimpl.cpp,v
+retrieving revision 1.2
+diff -u -r1.2 qcopimpl.cpp
+--- qcop/qcopimpl.cpp 2 Mar 2005 19:23:54 -0000 1.2
++++ qcop/qcopimpl.cpp 3 May 2007 03:09:36 -0000
+@@ -46,7 +46,7 @@
+
+ int doqcopimpl (int argc, char *argv[])
+ {
+- qInstallMsgHandler( disableqdebug );
++ //qInstallMsgHandler( disableqdebug );
+
+ if ( argc > 1 ) {
+ QString opt = argv[1];
diff --git a/recipes/opie-qcop/opie-qcop.inc b/recipes/opie-qcop/opie-qcop.inc
new file mode 100644
index 0000000000..b9b0309913
--- /dev/null
+++ b/recipes/opie-qcop/opie-qcop.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Opie QCOP IPC Client"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/qcop"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/qcop ${D}${bindir}/qcop
+}
diff --git a/recipes/opie-qcop/opie-qcop_1.2.2.bb b/recipes/opie-qcop/opie-qcop_1.2.2.bb
new file mode 100644
index 0000000000..f2ba1e4701
--- /dev/null
+++ b/recipes/opie-qcop/opie-qcop_1.2.2.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/qcop"
diff --git a/recipes/opie-qcop/opie-qcop_1.2.3.bb b/recipes/opie-qcop/opie-qcop_1.2.3.bb
new file mode 100644
index 0000000000..c62004a1db
--- /dev/null
+++ b/recipes/opie-qcop/opie-qcop_1.2.3.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/qcop \
+ file://unbreak-logging.patch;patch=1"
diff --git a/recipes/opie-qcop/opie-qcop_1.2.4.bb b/recipes/opie-qcop/opie-qcop_1.2.4.bb
new file mode 100644
index 0000000000..c62004a1db
--- /dev/null
+++ b/recipes/opie-qcop/opie-qcop_1.2.4.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/qcop \
+ file://unbreak-logging.patch;patch=1"
diff --git a/recipes/opie-qcop/opie-qcop_cvs.bb b/recipes/opie-qcop/opie-qcop_cvs.bb
new file mode 100644
index 0000000000..01a1d1b407
--- /dev/null
+++ b/recipes/opie-qcop/opie-qcop_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+PR = "r3"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/qcop \
+ file://unbreak-logging.patch;patch=1"