aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-symlinker
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opie-symlinker')
-rw-r--r--recipes/opie-symlinker/opie-symlinker.inc17
-rw-r--r--recipes/opie-symlinker/opie-symlinker_1.2.2.bb5
-rw-r--r--recipes/opie-symlinker/opie-symlinker_1.2.3.bb4
-rw-r--r--recipes/opie-symlinker/opie-symlinker_1.2.4.bb4
-rw-r--r--recipes/opie-symlinker/opie-symlinker_cvs.bb5
5 files changed, 35 insertions, 0 deletions
diff --git a/recipes/opie-symlinker/opie-symlinker.inc b/recipes/opie-symlinker/opie-symlinker.inc
new file mode 100644
index 0000000000..713ead3e89
--- /dev/null
+++ b/recipes/opie-symlinker/opie-symlinker.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Enables apps on external media"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "opie-update-symlinks"
+APPTYPE = "binary"
+
+
+S = "${WORKDIR}/symlinker"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/
+ install -m 0755 ${S}/opie-update-symlinks ${D}${palmtopdir}/bin/
+}
+
diff --git a/recipes/opie-symlinker/opie-symlinker_1.2.2.bb b/recipes/opie-symlinker/opie-symlinker_1.2.2.bb
new file mode 100644
index 0000000000..1f46355811
--- /dev/null
+++ b/recipes/opie-symlinker/opie-symlinker_1.2.2.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/symlinker "
diff --git a/recipes/opie-symlinker/opie-symlinker_1.2.3.bb b/recipes/opie-symlinker/opie-symlinker_1.2.3.bb
new file mode 100644
index 0000000000..1c4c137b1f
--- /dev/null
+++ b/recipes/opie-symlinker/opie-symlinker_1.2.3.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/symlinker "
diff --git a/recipes/opie-symlinker/opie-symlinker_1.2.4.bb b/recipes/opie-symlinker/opie-symlinker_1.2.4.bb
new file mode 100644
index 0000000000..1c4c137b1f
--- /dev/null
+++ b/recipes/opie-symlinker/opie-symlinker_1.2.4.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/symlinker "
diff --git a/recipes/opie-symlinker/opie-symlinker_cvs.bb b/recipes/opie-symlinker/opie-symlinker_cvs.bb
new file mode 100644
index 0000000000..01cc735823
--- /dev/null
+++ b/recipes/opie-symlinker/opie-symlinker_cvs.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/core/symlinker "