aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/palantir/palantir_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/palantir/palantir_2.7.bb')
-rw-r--r--recipes/palantir/palantir_2.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/palantir/palantir_2.7.bb b/recipes/palantir/palantir_2.7.bb
new file mode 100644
index 0000000000..ad1b2f6a19
--- /dev/null
+++ b/recipes/palantir/palantir_2.7.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Palantir - a multichannel interactive streaming solution"
+LICENSE = "GPLv2"
+DEPENDS = "jpeg libgsm"
+
+SRC_URI = "http://www.fastpath.it/products/palantir/pub/palantir-${PV}.tgz"
+
+S = "${WORKDIR}/palantir-${PV}/server"
+
+TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
+
+export BASE_DIR="${prefix}"
+
+do_install() {
+ sed -i -e s:chown:echo:g -e s:chmod:echo:g Makefile
+ mkdir -p ${D}/var/log/palantir
+ LOG_FILE="${D}/var/log/palantir" OWNER="${USER}" BASE_DIR="${D}${prefix}" oe_runmake install
+ rm ${D}/${datadir}/palantir/telmu_pipe
+}
+
+FILES_${PN} += "${datadir}/palantir/"
+
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^palantir:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/run/palantir --no-create-home palantir --ingroup palantir -g palantir
+ mkfifo ${datadir}/palantir/telmu_pipe
+ chown palantir ${datadir}/palantir/*
+ chmod 600 ${datadir}/palantir/telmu_pipe
+}
+
+
+pkg_postrm_${PN} () {
+ deluser palantir || true
+}
+