summaryrefslogtreecommitdiffstats
path: root/recipes/pdm/pdm_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pdm/pdm_1.0.bb')
-rw-r--r--recipes/pdm/pdm_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/pdm/pdm_1.0.bb b/recipes/pdm/pdm_1.0.bb
new file mode 100644
index 0000000000..d80e836e8a
--- /dev/null
+++ b/recipes/pdm/pdm_1.0.bb
@@ -0,0 +1,21 @@
+SECTION = "x11/base"
+LICENSE = "GPL"
+DESCRIPTION = "pdm is a minimal session manager for GUIs."
+
+SRC_URI="http://www.penguru.net/download/${PN}-${PV}.tar.gz \
+ file://pdm-1.0-changes.patch;patch=1 \
+ file://pdm.conf \
+ file://xfce \
+ file://mythtv"
+
+do_install() {
+ install -d ${D}${sbindir} \
+ ${D}${sysconfdir}/pdm/sessions \
+ ${D}${sysconfdir}/pdm/plugins
+
+ install -m 0755 pdm ${D}${sbindir}/pdm
+ install -m 0644 conf/pdm.conf* ${D}${sysconfdir}/pdm/
+ install -m 0644 ${WORKDIR}/pdm.conf ${D}${sysconfdir}/pdm/
+ install -m 755 ${WORKDIR}/xfce ${D}${sysconfdir}/pdm/sessions/xfce
+ install -m 755 ${WORKDIR}/mythtv ${D}${sysconfdir}/pdm/sessions/mythtv
+}