aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl-native_5.8.8.bb')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index e3d73845fc..57e9e1c394 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -85,5 +85,11 @@ do_stage_append() {
install $i ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE
done
}
+do_stage_append_nylon() {
+ # get rid of definitions not supported by the gcc version we use for nylon...
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR_HOST}/perl/config.sh; do
+ perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
+ done
+}
PARALLEL_MAKE = ""