aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl-native_5.8.8.bb')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index b265e5897c..dbff4c5c40 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r20"
+PR = "r21"
NATIVE_INSTALL_WORKS = "1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -94,6 +94,11 @@ do_install() {
# Make sure CPAN is configured
sed -e "s,@SYSROOTBASE@,${base_prefix}," ${WORKDIR}/CPAN-Config.pm > \
${D}${libdir}/perl/${PV}/CPAN/Config.pm
+
+ # Make sure we use /usr/bin/env perl
+ for PERLSCRIPT in `grep -rIl ${bindir}/perl ${D}${bindir}`; do
+ sed -i -e 's|^#!${bindir}/perl|#!/usr/bin/env perl|' $PERLSCRIPT
+ done
}
do_install_append_nylon() {