aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl_5.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl_5.10.1.bb')
-rw-r--r--recipes/perl/perl_5.10.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index a58b8ec626..d8c374bb34 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r17"
+PR = "r18"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -154,6 +154,10 @@ do_configure() {
sed -i -e "s,\(need_va_copy=\)'undef',\1'define',g" \
config.sh-${TARGET_ARCH}-${TARGET_OS}
;;
+ arm)
+ sed -i -e "s,\(d_u32align=\)'undef',\1'define',g" \
+ config.sh-${TARGET_ARCH}-${TARGET_OS}
+ ;;
esac
if test "${MACHINE}" != "native"; then