summaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libclass-factory-util-perl_1.7.bb15
-rw-r--r--recipes/perl/libclass-inspector-perl_1.24.bb14
-rw-r--r--recipes/perl/libclass-singleton-perl_1.4.bb14
-rw-r--r--recipes/perl/libdatetime-format-builder-perl_0.80.bb17
-rw-r--r--recipes/perl/libdatetime-format-iso8601-perl_0.07.bb16
-rw-r--r--recipes/perl/libdatetime-locale-perl_0.45.bb17
-rw-r--r--recipes/perl/libdatetime-perl_0.61.bb17
-rw-r--r--recipes/perl/libdatetime-timezone-perl_1.21.bb18
-rw-r--r--recipes/perl/libhttp-cache-transparent-perl_1.0.bb5
-rw-r--r--recipes/perl/libimage-size-perl_3.230.bb14
-rw-r--r--recipes/perl/liblist-moreutils-perl_0.22.bb15
-rw-r--r--recipes/perl/libmime-tools-perl_5.427.bb3
-rw-r--r--recipes/perl/libnetaddr-ip-perl_4.027.bb3
-rw-r--r--recipes/perl/libsoap-lite-perl_0.710.08.bb19
-rw-r--r--recipes/perl/libsoap-lite-perl_0.712.bb25
-rw-r--r--recipes/perl/libtask-weaken-perl_1.03.bb14
-rw-r--r--recipes/perl/libterm-progressbar-perl_2.09.bb5
-rw-r--r--recipes/perl/libtest-exception-perl_0.22.bb7
-rw-r--r--recipes/perl/libxml-libxml-perl_1.70.bb7
-rw-r--r--recipes/perl/libxml-namespacesupport-perl_1.10.bb16
-rw-r--r--recipes/perl/libxml-namespacesupport-perl_1.11.bb16
-rw-r--r--recipes/perl/libxml-sax-perl_0.96.bb3
-rw-r--r--recipes/perl/libxml-simple-perl_2.18.bb6
-rw-r--r--recipes/perl/libxml-twig-perl_3.33.bb17
-rw-r--r--recipes/perl/libxml-twig-perl_3.35.bb17
-rw-r--r--recipes/perl/libxml-xpath-perl_1.13.bb14
26 files changed, 267 insertions, 67 deletions
diff --git a/recipes/perl/libclass-factory-util-perl_1.7.bb b/recipes/perl/libclass-factory-util-perl_1.7.bb
new file mode 100644
index 0000000000..2661688984
--- /dev/null
+++ b/recipes/perl/libclass-factory-util-perl_1.7.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Class::Factory::Util - Provide utility methods for factory classes"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "libmodule-build-perl-native"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Class-Factory-Util-${PV}.tar.gz"
+SRC_URI[md5sum] = "aebd79da361b676a7ecd3245fc3d1b3f"
+SRC_URI[sha256sum] = "6c516b445b44f87363fb3a148431d31e9ecb5e6f21fb6481c89b2406b6692e26"
+
+S = "${WORKDIR}/Class-Factory-Util-${PV}"
+
+inherit cpan_build
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libclass-inspector-perl_1.24.bb b/recipes/perl/libclass-inspector-perl_1.24.bb
new file mode 100644
index 0000000000..176c68fa23
--- /dev/null
+++ b/recipes/perl/libclass-inspector-perl_1.24.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Class::Inspector - Get information about a class and its structure"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Inspector-${PV}.tar.gz"
+
+S = "${WORKDIR}/Class-Inspector-${PV}"
+SRC_URI[md5sum] = "609189b49f64d329a6e413e0a6d8724a"
+SRC_URI[sha256sum] = "0a70cac1276d33e5408d3ad4297b3732a2299f7ff463d94ab7d384f2c6b11a66"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libclass-singleton-perl_1.4.bb b/recipes/perl/libclass-singleton-perl_1.4.bb
new file mode 100644
index 0000000000..e2d68e27ba
--- /dev/null
+++ b/recipes/perl/libclass-singleton-perl_1.4.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Class::Singleton - Implementation of a "Singleton" class"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AB/ABW/Class-Singleton-${PV}.tar.gz"
+
+S = "${WORKDIR}/Class-Singleton-${PV}"
+SRC_URI[md5sum] = "a18b108ab97e2107cbbe816d2b3e2ee3"
+SRC_URI[sha256sum] = "cfafc6e7c842e04fc11cc3e700551461a6aaa0b139470273aea2f29026e79150"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libdatetime-format-builder-perl_0.80.bb b/recipes/perl/libdatetime-format-builder-perl_0.80.bb
new file mode 100644
index 0000000000..7fa801e222
--- /dev/null
+++ b/recipes/perl/libdatetime-format-builder-perl_0.80.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "DateTime::Format::Builder - Create DateTime parser classes and objects"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = " libclass-factory-util-perl-native libdatetime-perl-native libdatetime-format-strptime-perl-native \
+ libtask-weaken-perl-native "
+RDEPENDS_${PN} = " libclass-factory-util-perl libdatetime-perl libdatetime-format-strptime-perl libtask-weaken-perl "
+PR = "r1"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Builder-${PV}.tar.gz"
+SRC_URI[md5sum] = "f6c5d5a17b5b7478ff555a2d3cce5136"
+SRC_URI[sha256sum] = "9250fe0f7312fe6b12295280a10968d665bee563170477a272a099464cd02c89"
+
+S = "${WORKDIR}/DateTime-Format-Builder-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libdatetime-format-iso8601-perl_0.07.bb b/recipes/perl/libdatetime-format-iso8601-perl_0.07.bb
new file mode 100644
index 0000000000..7110c38c91
--- /dev/null
+++ b/recipes/perl/libdatetime-format-iso8601-perl_0.07.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "DateTime::Format::ISO8601 - Parses ISO8601 formats"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = " libdatetime-perl-native libdatetime-format-builder-perl-native "
+RDEPENDS_${PN} = " libdatetime-perl libdatetime-format-builder-perl "
+PR = "r1"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/J/JH/JHOBLITT/DateTime-Format-ISO8601-${PV}.tar.gz"
+SRC_URI[md5sum] = "debb51180d0318ae09cad01c544a1d7d"
+SRC_URI[sha256sum] = "e362d6a006934854d041b3833b106bd1489278ee8348ee3c24bbc5ed87ed9618"
+
+S = "${WORKDIR}/DateTime-Format-ISO8601-${PV}"
+
+inherit cpan_build
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libdatetime-locale-perl_0.45.bb b/recipes/perl/libdatetime-locale-perl_0.45.bb
new file mode 100644
index 0000000000..fc712d5ef3
--- /dev/null
+++ b/recipes/perl/libdatetime-locale-perl_0.45.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "DateTime::Locale - Localization support for DateTime.pm"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+HOMEPAGE = "http://datetime.perl.org/"
+DEPENDS = "liblist-moreutils-perl-native libparams-validate-perl-native"
+RDEPENDS_${PN} = "liblist-moreutils-perl libparams-validate-perl"
+PR = "r1"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Locale-${PV}.tar.gz"
+SRC_URI[md5sum] = "8ba6a4b70f8fa7d987529c2e2c708862"
+SRC_URI[sha256sum] = "8aa1b8db0baccc26ed88f8976a228d2cdf4f6ed4e10fc88c1501ecd8f3ccaf9c"
+
+S = "${WORKDIR}/DateTime-Locale-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libdatetime-perl_0.61.bb b/recipes/perl/libdatetime-perl_0.61.bb
new file mode 100644
index 0000000000..46ac8cd6ab
--- /dev/null
+++ b/recipes/perl/libdatetime-perl_0.61.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "DateTime - A date and time object"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "libtest-exception-perl-native libdatetime-timezone-perl-native libdatetime-locale-perl-native "
+RDEPENDS_${PN} = "libtest-exception-perl libdatetime-timezone-perl libdatetime-locale-perl \
+ perl-module-scalar-util perl-module-pod-man perl-module-time-local"
+PR = "r1"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-${PV}.tar.gz"
+SRC_URI[md5sum] = "0802efbc53eb11a09d1528223cd52e88"
+SRC_URI[sha256sum] = "74b561a73dc060b9be3b03ddeafd93b5995673abe71f4614fe402c3eb51d236f"
+
+S = "${WORKDIR}/DateTime-${PV}"
+
+inherit cpan_build
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libdatetime-timezone-perl_1.21.bb b/recipes/perl/libdatetime-timezone-perl_1.21.bb
new file mode 100644
index 0000000000..01d5367b7d
--- /dev/null
+++ b/recipes/perl/libdatetime-timezone-perl_1.21.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "DateTime::TimeZone - Time zone object base class and factory"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+HOMEPAGE = "http://datetime.perl.org/"
+DEPENDS = "libclass-singleton-perl-native libparams-validate-perl-native"
+RDEPENDS_${PN} = "libclass-singleton-perl libparams-validate-perl \
+ perl-module-test-more perl-module-cwd"
+PR = "r1"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-TimeZone-${PV}.tar.gz"
+SRC_URI[md5sum] = "442c2754c061b61e30f04e57954abba3"
+SRC_URI[sha256sum] = "febec17fc7428e5ff897f1772d3e230f2b8e3afbc94558dc2a60b092608c90c6"
+
+S = "${WORKDIR}/DateTime-TimeZone-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libhttp-cache-transparent-perl_1.0.bb b/recipes/perl/libhttp-cache-transparent-perl_1.0.bb
index 5248d593db..3f28153bc6 100644
--- a/recipes/perl/libhttp-cache-transparent-perl_1.0.bb
+++ b/recipes/perl/libhttp-cache-transparent-perl_1.0.bb
@@ -1,9 +1,10 @@
DESCRIPTION = "HTTP::Cache::Transparent - Cache the result of http get-requests persistently."
SECTION = "libs"
LICENSE = "Artistic|GPL"
-PR = "r0"
+PR = "r1"
-DEPENDS += "libwww-perl liburi-perl libhtml-tagset-perl libhtml-parser-perl"
+DEPENDS += "libwww-perl-native"
+RDEPENDS_${PN} += "libwww-perl"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MATTIASH/HTTP-Cache-Transparent-${PV}.tar.gz"
diff --git a/recipes/perl/libimage-size-perl_3.230.bb b/recipes/perl/libimage-size-perl_3.230.bb
new file mode 100644
index 0000000000..539463e8b3
--- /dev/null
+++ b/recipes/perl/libimage-size-perl_3.230.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Image::Size read the dimensions of an image in several popular formats"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RJ/RJRAY/Image-Size-${PV}.tar.gz"
+SRC_URI[md5sum] = "17b5cc123a522aa3c4ca842094d0c0ba"
+SRC_URI[sha256sum] = "b2cf429c306fc865c551843bb2db42c24e28286964219758f315fce7d2aa76ae"
+
+S = "${WORKDIR}/Image-Size-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/liblist-moreutils-perl_0.22.bb b/recipes/perl/liblist-moreutils-perl_0.22.bb
new file mode 100644
index 0000000000..352ae4344d
--- /dev/null
+++ b/recipes/perl/liblist-moreutils-perl_0.22.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "List::MoreUtils - Provide the stuff missing in List::Util"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+HOMEPAGE = "http://datetime.perl.org/"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/V/VP/VPARSEVAL/List-MoreUtils-${PV}.tar.gz"
+SRC_URI[md5sum] = "3a6ec506f40662ab1296c48c5eb72016"
+SRC_URI[sha256sum] = "b4948b26851d9d9ac611eb487ecb92815dc3c5ee64e414bc67211b48590f62b7"
+
+S = "${WORKDIR}/List-MoreUtils-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libmime-tools-perl_5.427.bb b/recipes/perl/libmime-tools-perl_5.427.bb
index 480c1ebd46..2eb2410d09 100644
--- a/recipes/perl/libmime-tools-perl_5.427.bb
+++ b/recipes/perl/libmime-tools-perl_5.427.bb
@@ -11,6 +11,7 @@ RDEPENDS_${PN} += "\
libio-stringy-perl \
libmailtools-perl \
libtest-pod-perl \
+ libtimedate-perl \
perl-module-file-path \
perl-module-file-spec \
perl-module-file-temp \
@@ -21,7 +22,7 @@ RDEPENDS_${PN} += "\
"
BBCLASSEXTEND = "native"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DO/DONEILL/MIME-tools-${PV}.tar.gz;name=mime-tools-perl-${PV}"
SRC_URI[mime-tools-perl-5.427.md5sum] = "4333caa7238cb9eafb5f7fb39fcbd8e7"
diff --git a/recipes/perl/libnetaddr-ip-perl_4.027.bb b/recipes/perl/libnetaddr-ip-perl_4.027.bb
index 155b285173..07b5ec1242 100644
--- a/recipes/perl/libnetaddr-ip-perl_4.027.bb
+++ b/recipes/perl/libnetaddr-ip-perl_4.027.bb
@@ -1,11 +1,10 @@
DESCRIPTION = "Perl module to manage IPv4 and IPv6 addresses and subnets"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-DEPENDS = "libtest-pod-perl-native"
RDEPENDS_${PN} += "perl-module-test-more"
BBCLASSEXTEND = "native"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKER/NetAddr-IP-${PV}.tar.gz;name=netaddr-ip-perl-${PV}"
SRC_URI[netaddr-ip-perl-4.027.md5sum] = "c4a21a76e5b1b9f4c8e9810b78559d7b"
diff --git a/recipes/perl/libsoap-lite-perl_0.710.08.bb b/recipes/perl/libsoap-lite-perl_0.710.08.bb
deleted file mode 100644
index 6d54766023..0000000000
--- a/recipes/perl/libsoap-lite-perl_0.710.08.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Client and server side SOAP implementation"
-SECTION = "libs"
-LICENSE = "Artistic|GPL"
-PR = "r1"
-
-SRC_URI = "http://www.cpan.org/authors/id/M/MK/MKUTTER/SOAP-Lite-${PV}.tar.gz"
-
-S = "${WORKDIR}/SOAP-Lite-${PV}"
-
-inherit cpan
-
-do_configure_prepend () {
- sed -i '/^use diagnostics;$/d' Makefile.PL
-}
-
-BBCLASSEXTEND="native"
-
-SRC_URI[md5sum] = "e7869ad91fee76cc1782fe29fe3a989d"
-SRC_URI[sha256sum] = "efe7dd9a1c6993d475ae1a653c5fa97a76a36accd468d49b030d81880ca11bef"
diff --git a/recipes/perl/libsoap-lite-perl_0.712.bb b/recipes/perl/libsoap-lite-perl_0.712.bb
new file mode 100644
index 0000000000..47d9c524da
--- /dev/null
+++ b/recipes/perl/libsoap-lite-perl_0.712.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Client and server side SOAP implementation"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = " libmime-tools-perl-native libwww-perl-native libxml-parser-perl-native libtask-weaken-perl-native \
+ libio-socket-ssl-perl-native libclass-inspector-perl-native "
+RDEPENDS_${PN} = " libmime-tools-perl libwww-perl libxml-parser-perl libtask-weaken-perl \
+ libio-socket-ssl-perl libclass-inspector-perl \
+ perl-module-scalar-util perl-module-constant"
+PR = "r2"
+
+SRC_URI = "http://www.cpan.org/authors/id/M/MK/MKUTTER/SOAP-Lite-${PV}.tar.gz"
+
+S = "${WORKDIR}/SOAP-Lite-${PV}"
+
+inherit cpan
+
+do_configure_prepend () {
+ sed -i '/^use diagnostics;$/d' Makefile.PL
+}
+
+BBCLASSEXTEND="native"
+
+SRC_URI[md5sum] = "fd71a0c0feff85f670ab4b2e571652a8"
+SRC_URI[sha256sum] = "1767494854716afde371c569cd08edc8bcb5d53360f351c87d6ddfe30c33d492"
+
diff --git a/recipes/perl/libtask-weaken-perl_1.03.bb b/recipes/perl/libtask-weaken-perl_1.03.bb
new file mode 100644
index 0000000000..1c13d2de7b
--- /dev/null
+++ b/recipes/perl/libtask-weaken-perl_1.03.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Task::Weaken - Ensure that a platform has weaken support"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Task-Weaken-${PV}.tar.gz"
+SRC_URI[md5sum] = "056ce36c576450d22e6b23b4dbfacd02"
+SRC_URI[sha256sum] = "fb1de84c81c523147f4007c559d3ac38fa474b2999f68b14387bb67e061ca8d0"
+
+S = "${WORKDIR}/Task-Weaken-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libterm-progressbar-perl_2.09.bb b/recipes/perl/libterm-progressbar-perl_2.09.bb
index ca7ff83472..4ce148ace9 100644
--- a/recipes/perl/libterm-progressbar-perl_2.09.bb
+++ b/recipes/perl/libterm-progressbar-perl_2.09.bb
@@ -1,8 +1,9 @@
DESCRIPTION = "Term::ProgressBar - provide a progress meter on a standard terminal"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-PR = "r0"
-DEPENDS = "libtermreadkey-perl libclass-methodmaker-perl"
+PR = "r1"
+DEPENDS = "libtermreadkey-perl-native libclass-methodmaker-perl-native"
+RDEPENDS_${PN} = "libtermreadkey-perl libclass-methodmaker-perl"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FL/FLUFFY/Term-ProgressBar-${PV}.tar.gz"
diff --git a/recipes/perl/libtest-exception-perl_0.22.bb b/recipes/perl/libtest-exception-perl_0.22.bb
index 737dd79168..1e522a9cc8 100644
--- a/recipes/perl/libtest-exception-perl_0.22.bb
+++ b/recipes/perl/libtest-exception-perl_0.22.bb
@@ -5,13 +5,14 @@ DEPENDS += "libsub-uplevel-perl-native"
RDEPENDS_${PN} += "perl-module-base perl-module-carp perl-module-strict \
libsub-uplevel-perl perl-module-test-builder \
perl-module-warnings"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Exception-${PV}.tar.gz"
+SRC_URI[md5sum] = "dcf44183af3d26b14d7f989fc5ee1117"
+SRC_URI[sha256sum] = "98b129aa38a729f9c63b3ae2118b500f76bcf3456bb03a5f049f67ddea7efc81"
S = "${WORKDIR}/Test-Exception-${PV}"
inherit cpan
-SRC_URI[md5sum] = "dcf44183af3d26b14d7f989fc5ee1117"
-SRC_URI[sha256sum] = "98b129aa38a729f9c63b3ae2118b500f76bcf3456bb03a5f049f67ddea7efc81"
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libxml-libxml-perl_1.70.bb b/recipes/perl/libxml-libxml-perl_1.70.bb
index f298ac873f..373885e01a 100644
--- a/recipes/perl/libxml-libxml-perl_1.70.bb
+++ b/recipes/perl/libxml-libxml-perl_1.70.bb
@@ -2,10 +2,14 @@ DESCRIPTION = "XML-LibXML"
SECTION = "libs"
LICENSE = ""
DEPENDS += "libxml2 \
+ libxml-sax-perl-native \
+ zlib \
+"
+RDEPENDS_${PN} += "libxml2 \
libxml-sax-perl \
zlib \
"
-PR = "r0"
+PR = "r3"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PA/PAJAS/XML-LibXML-${PV}.tar.gz;name=libxml \
file://libxml-libxml-perl-disable-libxml2-check.patch \
@@ -22,3 +26,4 @@ EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
BBCLASSEXTEND = "native"
CFLAGS += " -D_GNU_SOURCE "
+BUILD_CFLAGS += " -D_GNU_SOURCE "
diff --git a/recipes/perl/libxml-namespacesupport-perl_1.10.bb b/recipes/perl/libxml-namespacesupport-perl_1.10.bb
deleted file mode 100644
index 3b49cef480..0000000000
--- a/recipes/perl/libxml-namespacesupport-perl_1.10.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "XML-NamespaceSupport"
-SECTION = "libs"
-LICENSE = ""
-PR = "r0"
-
-SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PE/PERIGRIN/XML-NamespaceSupport-${PV}.tar.gz;name=namespacesupport"
-
-SRC_URI[namespacesupport.md5sum] = "0a760067d4b517672f064e911679c509"
-SRC_URI[namespacesupport.sha256sum] = "a57357ac22959a5093a19177a0d541a478595d538afef659c19ae1e75849833e"
-
-S = "${WORKDIR}/XML-NamespaceSupport-${PV}"
-
-inherit cpan
-
-BBCLASSEXTEND="native"
-
diff --git a/recipes/perl/libxml-namespacesupport-perl_1.11.bb b/recipes/perl/libxml-namespacesupport-perl_1.11.bb
new file mode 100644
index 0000000000..3816259800
--- /dev/null
+++ b/recipes/perl/libxml-namespacesupport-perl_1.11.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "XML-NamespaceSupport"
+SECTION = "libs"
+LICENSE = ""
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PE/PERIGRIN/XML-NamespaceSupport-${PV}.tar.gz"
+SRC_URI[md5sum] = "222cca76161cd956d724286d36b607da"
+SRC_URI[sha256sum] = "6d8151f0a3f102313d76b64bfd1c2d9ed46bfe63a16f038e7d860fda287b74ea"
+
+
+S = "${WORKDIR}/XML-NamespaceSupport-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
+
diff --git a/recipes/perl/libxml-sax-perl_0.96.bb b/recipes/perl/libxml-sax-perl_0.96.bb
index 260a98f809..0e2cbc7663 100644
--- a/recipes/perl/libxml-sax-perl_0.96.bb
+++ b/recipes/perl/libxml-sax-perl_0.96.bb
@@ -2,7 +2,8 @@ DESCRIPTION = "XML-SAX"
SECTION = "libs"
LICENSE = ""
DEPENDS += "libxml-namespacesupport-perl-native"
-PR = "r0"
+RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp"
+PR = "r1"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz;name=sax"
SRC_URI[sax.md5sum] = "bdcd4119a62505184e211e9dfaef0ab1"
diff --git a/recipes/perl/libxml-simple-perl_2.18.bb b/recipes/perl/libxml-simple-perl_2.18.bb
index 0c9668d3e3..cc69ec288c 100644
--- a/recipes/perl/libxml-simple-perl_2.18.bb
+++ b/recipes/perl/libxml-simple-perl_2.18.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "XML::Simple - Easy API to maintain XML (esp config files)"
SECTION = "libs"
LICENSE = "Artistic"
-DEPENDS += "libxml-parser-perl"
-RDEPENDS_${PN} += "libxml-parser-perl"
-PR = "r2"
+DEPENDS += "libxml-sax-perl-native"
+RDEPENDS_${PN} += "libxml-sax-perl"
+PR = "r4"
SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
diff --git a/recipes/perl/libxml-twig-perl_3.33.bb b/recipes/perl/libxml-twig-perl_3.33.bb
deleted file mode 100644
index e10fa58791..0000000000
--- a/recipes/perl/libxml-twig-perl_3.33.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "XML::Twig - A perl module for processing huge XML documents in tree mode."
-SECTION = "libs"
-LICENSE = "Artistic|GPL"
-HOMEPAGE = "http://www.xmltwig.com/"
-DEPENDS += "libxml-parser-perl"
-PR = "r3"
-
-SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/XML-Twig-${PV}-upstream-keeps-changing-this-tarball-so-we-mirror-our-own.tar.gz"
-
-S = "${WORKDIR}/XML-Twig-${PV}"
-
-inherit cpan
-
-BBCLASSEXTEND="native"
-
-SRC_URI[md5sum] = "918f8fba33efe9cf5bc07907c6e46556"
-SRC_URI[sha256sum] = "630241ba64685a264d6037cbfed29476ab36fce652746ad5966fcfc9d810abdc"
diff --git a/recipes/perl/libxml-twig-perl_3.35.bb b/recipes/perl/libxml-twig-perl_3.35.bb
new file mode 100644
index 0000000000..522e06f510
--- /dev/null
+++ b/recipes/perl/libxml-twig-perl_3.35.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "XML::Twig - A perl module for processing huge XML documents in tree mode."
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+HOMEPAGE = "http://www.xmltwig.com/"
+DEPENDS += "libxml-parser-perl-native"
+RDEPENDS_${PN} += "libxml-parser-perl"
+PR = "r1"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIROD/XML-Twig-${PV}.tar.gz"
+SRC_URI[md5sum] = "867449a4c53c628dd16bdc8de49cfc88"
+SRC_URI[sha256sum] = "aa5b841ffe832feca7db16ad4781f01a0bc29ea3e0eb4784ab4d4c12db5922c7"
+
+S = "${WORKDIR}/XML-Twig-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"
diff --git a/recipes/perl/libxml-xpath-perl_1.13.bb b/recipes/perl/libxml-xpath-perl_1.13.bb
new file mode 100644
index 0000000000..d1f28c4655
--- /dev/null
+++ b/recipes/perl/libxml-xpath-perl_1.13.bb
@@ -0,0 +1,14 @@
+DESCRIPTION ="XML::XPath - a set of modules for parsing and evaluating XPath statement"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MS/MSERGEANT/XML-XPath-${PV}.tar.gz"
+SRC_URI[md5sum] = "b5919d9220d83982feb6e2321850c5d7"
+SRC_URI[sha256sum] = "2a49c2df34007588397bdf7ae5f122df72a9499df5cbec8fbc6ad4a31a775576"
+
+S = "${WORKDIR}/XML-XPath-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND="native"