aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl-5.10.1/perl-configpm-switch.patch6
-rw-r--r--recipes/perl/perl-5.8.8/perl-configpm-switch.patch6
-rw-r--r--recipes/perl/perl-native_5.10.1.bb2
-rw-r--r--recipes/perl/perl-native_5.8.8.bb2
-rw-r--r--recipes/perl/perl_5.10.1.bb4
-rw-r--r--recipes/perl/perl_5.8.8.bb2
6 files changed, 11 insertions, 11 deletions
diff --git a/recipes/perl/perl-5.10.1/perl-configpm-switch.patch b/recipes/perl/perl-5.10.1/perl-configpm-switch.patch
index 1aacd35189..8becb8e33a 100644
--- a/recipes/perl/perl-5.10.1/perl-configpm-switch.patch
+++ b/recipes/perl/perl-5.10.1/perl-configpm-switch.patch
@@ -1,6 +1,6 @@
This patch is used for perl-native only. It enables the switching of
configuration files between Config_heavy.pl and
-Config_heavy-target.pl by setting the environment variables
+Config_heavy-$TARGET_SYS.pl by setting the environment variables
PERLCONFIGTARGET - the later containing settings for the target while
the former contains those for the host. This will allow cpan.bbclass
to use the settings appropriate for the native and/or target builds
@@ -24,9 +24,9 @@ values would be valid for the host only.
sub AUTOLOAD {
- require 'Config_heavy.pl';
+ my $cfgfile = 'Config_heavy.pl';
-+ if (defined $ENV{PERLCONFIGTARGET} and $ENV{PERLCONFIGTARGET} eq "yes")
++ if (defined $ENV{PERLCONFIGTARGET} and $ENV{PERLCONFIGTARGET} ne "")
+ {
-+ $cfgfile = 'Config_heavy-target.pl';
++ $cfgfile = "Config_heavy-$ENV{PERLCONFIGTARGET}.pl";
+ }
+ require $cfgfile;
goto \&launcher unless $Config::AUTOLOAD =~ /launcher$/;
diff --git a/recipes/perl/perl-5.8.8/perl-configpm-switch.patch b/recipes/perl/perl-5.8.8/perl-configpm-switch.patch
index 1aacd35189..8becb8e33a 100644
--- a/recipes/perl/perl-5.8.8/perl-configpm-switch.patch
+++ b/recipes/perl/perl-5.8.8/perl-configpm-switch.patch
@@ -1,6 +1,6 @@
This patch is used for perl-native only. It enables the switching of
configuration files between Config_heavy.pl and
-Config_heavy-target.pl by setting the environment variables
+Config_heavy-$TARGET_SYS.pl by setting the environment variables
PERLCONFIGTARGET - the later containing settings for the target while
the former contains those for the host. This will allow cpan.bbclass
to use the settings appropriate for the native and/or target builds
@@ -24,9 +24,9 @@ values would be valid for the host only.
sub AUTOLOAD {
- require 'Config_heavy.pl';
+ my $cfgfile = 'Config_heavy.pl';
-+ if (defined $ENV{PERLCONFIGTARGET} and $ENV{PERLCONFIGTARGET} eq "yes")
++ if (defined $ENV{PERLCONFIGTARGET} and $ENV{PERLCONFIGTARGET} ne "")
+ {
-+ $cfgfile = 'Config_heavy-target.pl';
++ $cfgfile = "Config_heavy-$ENV{PERLCONFIGTARGET}.pl";
+ }
+ require $cfgfile;
goto \&launcher unless $Config::AUTOLOAD =~ /launcher$/;
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 61d57f4b2b..8b275a2750 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r6"
+PR = "r7"
NATIVE_INSTALL_WORKS = "1"
# Not tested enough
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index dbff4c5c40..a7f85a30e6 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r21"
+PR = "r22"
NATIVE_INSTALL_WORKS = "1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 91434e284a..387755e4da 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r14"
+PR = "r15"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -211,7 +211,7 @@ do_stage() {
# target config, used by cpan.bbclass to extract version information
install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
- install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
+ install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-${TARGET_SYS}.pl
# target configuration
install lib/Config.pm ${STAGING_LIBDIR}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR}/perl/${PV}/ExtUtils/
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 69078e8b24..3e14bc34d2 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r36"
+PR = "r37"
# Major part of version
PVM = "5.8"